classification
Title: Document that 2.6 pickles of strings turn into pickles of unicode in 3.0
Type: Stage:
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder: Decide what to do with bytes/str when transferring pickles between 2.6 and 3.0
View: 2307
Assigned To: georg.brandl Nosy List: brett.cannon, georg.brandl, gvanrossum
Priority: release blocker Keywords:

Created on 2008-03-17 16:36 by brett.cannon, last changed 2008-03-17 17:11 by gvanrossum. This issue is now closed.

Messages (2)
msg63669 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-03-17 16:36
It turns out that unpickling a string from 2.6 leads to a Unicode string
in 3.0. That might fail since the encoding was never specified. This
should be documented probably in both 2.6 and 3.0.
msg63677 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-03-17 17:11
The issue is different; there is already a bug open for this (bug 2307).
History
Date User Action Args
2008-03-17 17:11:28gvanrossumsetstatus: open -> closed
resolution: not a bug
superseder: Decide what to do with bytes/str when transferring pickles between 2.6 and 3.0
messages: + msg63677
nosy: + gvanrossum
2008-03-17 16:36:41brett.cannoncreate