classification
Title: Make structseq's API look more like a nametuple.
Type: Stage:
Components: Extension Modules Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: brett.cannon, rhettinger
Priority: critical Keywords:

Created on 2008-03-17 16:34 by brett.cannon, last changed 2008-03-17 20:36 by rhettinger. This issue is now closed.

Messages (2)
msg63667 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-03-17 16:34
structseq and namedtuple should end up with a uniformed API.
msg63763 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2008-03-17 20:36
Closing as a duplicate of issue 1820.

I had been working on this, but there are limits to it. The constructors
are completely different so not all of the API can be synced.  The
__repr__ method is already synced-up.  All that is still needed is
_asdict(), _fields, and _replace().  The important parts like the
__repr__, matching most of the tuple API, and attribute access are
already done.
History
Date User Action Args
2008-03-17 20:36:00rhettingersetstatus: open -> closed
resolution: duplicate
messages: + msg63763
nosy: + rhettinger
title: Unify structseq and namedtuple's API -> Make structseq's API look more like a nametuple.
2008-03-17 20:08:57brett.cannonsetpriority: release blocker -> critical
2008-03-17 16:34:27brett.cannoncreate