classification
Title: Python 2.7.9 test_readline regression on CentOS 6
Type: behavior Stage: resolved
Components: Tests Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Importing readline produces erroneous output
View: 19884
Assigned To: Nosy List: berker.peksag, vlee
Priority: normal Keywords:

Created on 2014-12-20 02:39 by vlee, last changed 2014-12-20 07:38 by vlee. This issue is now closed.

Messages (3)
msg232957 - (view) Author: Vinson Lee (vlee) * Date: 2014-12-20 02:39
test_readline regressed from Python 2.7.8 to Python 2.7.9 on CentOS 6

Python 2.7.8
$ ./python -m test.regrtest test_readline
test_readline
1 test OK.

Python 2.7.9
$ ./python -m test.regrtest test_readline
[1/1] test_readline
test test_readline failed -- Traceback (most recent call last):
  File "Python-2.7.9/Lib/test/test_readline.py", line 56, in test_init
    self.assertEqual(stdout, b'')
AssertionError: '\x1b[?1034h' != ''

1 test failed:
    test_readline

$ cat /etc/redhat-release
CentOS release 6.6 (Final)

$ rpm -qa | grep readline
readline-6.0-4.el6.x86_64
compat-readline5-5.2-17.1.el6.x86_64
readline-devel-6.0-4.el6.x86_64
msg232965 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2014-12-20 07:25
This looks like a duplicate of issue 19884.
msg232966 - (view) Author: Vinson Lee (vlee) * Date: 2014-12-20 07:38
The regression is introduced with this commit.

commit fa06e2bb13a3e67a0641025483efb19ef569dbd9
Author: Victor Stinner <victor.stinner@gmail.com>
Date:   Thu Jul 24 12:22:24 2014 +0200

    Issue #19884: readline: Disable the meta modifier key if stdout is not a
    terminal to not write the ANSI sequence "\033[1034h" into stdout. This sequence
    is used on some terminal (ex: TERM=xterm-256color") to enable support of 8 bit
    characters.
History
Date User Action Args
2014-12-20 07:38:35vleesetmessages: + msg232966
2014-12-20 07:25:36berker.peksagsetstatus: open -> closed

superseder: Importing readline produces erroneous output
nosy: + berker.peksag

messages: + msg232965
type: behavior
resolution: duplicate
stage: resolved
2014-12-20 02:39:45vleecreate