classification
Title: Duplicate Paragraph in documentation for json module
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: berndca, docs@python, simeon.visser, terry.reedy
Priority: normal Keywords:

Created on 2014-12-08 14:08 by berndca, last changed 2014-12-13 23:52 by terry.reedy. This issue is now closed.

Messages (4)
msg232303 - (view) Author: (berndca) Date: 2014-12-08 14:08
There is a duplication of the first section of 18.2.2 (JSON) Encoders and Decoders of the python 2.7.9RC1 doc as well of the corresponding paragraph in 19.2.2 of the Python 3 docs.
msg232304 - (view) Author: Simeon Visser (simeon.visser) Date: 2014-12-08 14:20
What paragraph are you referring to? Various documented parameters are similar but I don't see duplicate paragraphs.
msg232581 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-12-13 00:43
The section documents JSONDecoder and then JSONEncoder.  Looking at the current 3.4 online docs, I do not see any significant duplication within either entry.  Even if there were duplication between, we might leave it to keep the entries complete in themselves.  But not seeing any, this is moot.
msg232625 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-12-13 23:52
Will reconsider if an actual duplication is presented.
History
Date User Action Args
2014-12-13 23:52:46terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg232625

stage: resolved
2014-12-13 00:43:07terry.reedysetnosy: + terry.reedy

messages: + msg232581
versions: - Python 3.3
2014-12-08 14:20:10simeon.vissersetnosy: + simeon.visser
messages: + msg232304
2014-12-08 14:08:55berndcacreate