classification
Title: More support for Visual Studio users on Windows?
Type: compile error Stage: resolved
Components: Versions:
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: SilentGhost, StoreIntegrator, r.david.murray
Priority: normal Keywords:

Created on 2014-12-06 12:24 by StoreIntegrator, last changed 2014-12-06 15:42 by r.david.murray. This issue is now closed.

Messages (3)
msg232240 - (view) Author: StoreIntegrator (StoreIntegrator) Date: 2014-12-06 12:24
Hi,

When using Python on Windows I always encounter plenty of errors which are simply frustrating. Typically issues compilation, linking, libraries which have nothing to do with functional coding in Python are numerous.

Do have a look at PTVS tools how an integrated UI can work...

And do try to get rid of the already for > 5 years existing BUGS like:
https://pytools.codeplex.com/workitem/2808

Simply frustrating to use Python this way.

J.
msg232242 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2014-12-06 13:54
This seem like an issue with numpy, not python. Perhaps installing using binary would be a better option for you? In any case, this need further elaborating at what the actual problem and the solution could be.
msg232245 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-12-06 15:42
Note also that there are going to be significant improvements in the Python Windows build system for 3.5.  Any further (specific, non-distutils) requests for improvement should be targeted against that version once issue 22919 has been integrated.  Please do open a new issue with *specific* problems if they are problems with the CPython compile itself or with distutils, as opposed to problems with a specific 3rd party project's compilation instructions...the latter should be reported to the 3rd party project first, and if the project determines it is rooted in a problem with CPython/distutils, it can then be reported upstream here with sufficient details for us to take action.
History
Date User Action Args
2014-12-06 15:42:03r.david.murraysetnosy: + r.david.murray
messages: + msg232245

resolution: not a bug -> third party
stage: resolved
2014-12-06 13:54:38SilentGhostsetstatus: open -> closed
versions: - Python 2.7, Python 3.2, Python 3.3, Python 3.4, Python 3.5, Python 3.6
nosy: + SilentGhost

messages: + msg232242

resolution: not a bug
2014-12-06 12:24:02StoreIntegratorcreate