classification
Title: Make traceback functions support negative limits
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Possible implementation of negative limit for traceback functions
View: 22619
Assigned To: Nosy List: demian.brecht, r.david.murray, vaultah
Priority: normal Keywords: patch

Created on 2014-12-01 15:59 by vaultah, last changed 2014-12-02 04:55 by berker.peksag. This issue is now closed.

Messages (4)
msg231943 - (view) Author: Dmitry Kazakov (vaultah) * Date: 2014-12-01 15:59
This is a complete implementation of negative limits for functions from traceback module (see this proposal - https://mail.python.org/pipermail/python-ideas/2014-August/029105.html). I also added some tests.
msg231945 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-12-01 16:17
This looks like a duplicate of issue 22619.  Were you under the impression you needed to open a new issue just in order to update your patch?  You would be better off posting the patch to issue 22619 and closing this one, unless I'm missing something.
msg231950 - (view) Author: Dmitry Kazakov (vaultah) * Date: 2014-12-01 17:05
Indeed, this is an exact duplicate, but I feel like that issue is an embarrassment: too many unnecessary actions, bad patches, and most of messages are totally useless. I wanted to start over for once, so I closed that issue. Pardon my initial ignorance.
msg231962 - (view) Author: Demian Brecht (demian.brecht) * (Python triager) Date: 2014-12-01 23:15
It's generally better to keep everything in one issue in order to preserve history and avoid confusion as you've now found :). I'd suggest closing this one and adding the patch to the initial report. Keeping history intact is important for reviewers.

Absolutely no need for embarrassment, we all start somewhere and have to learn processes and such along the way :)
History
Date User Action Args
2014-12-02 04:55:59berker.peksagsetsuperseder: Possible implementation of negative limit for traceback functions
resolution: duplicate
stage: resolved
2014-12-02 04:54:29vaultahsetfiles: - traceback_patch_2.diff
2014-12-02 04:49:55vaultahsetstatus: open -> closed
2014-12-01 23:15:18demian.brechtsetnosy: + demian.brecht
messages: + msg231962
2014-12-01 17:05:22vaultahsetmessages: + msg231950
2014-12-01 16:17:04r.david.murraysetnosy: + r.david.murray
messages: + msg231945
2014-12-01 15:59:28vaultahcreate