classification
Title: Integer type and __add__
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Tutorial and FAQ: how to call a method on an int
View: 20692
Assigned To: Nosy List: jordan, josh.r, sfalk
Priority: normal Keywords:

Created on 2014-11-26 14:32 by sfalk, last changed 2014-11-26 23:57 by berker.peksag. This issue is now closed.

Messages (3)
msg231711 - (view) Author: Sascha Falk (sfalk) Date: 2014-11-26 14:32
The following statement makes python report a syntactic error:
1.__add__(2)

The following works:
(1).__add__(2)
msg231719 - (view) Author: Jordan (jordan) Date: 2014-11-26 16:01
>1.< is lexed as a float constant 

>>> 1.
1.0
>>> 1.0.__add__(2)
3.0
>>> 1     .__add__(2)
3

Not sure how to procede
msg231733 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2014-11-26 23:36
This is a duplicate of #20692.
History
Date User Action Args
2014-11-26 23:57:11berker.peksagsetstatus: open -> closed
superseder: Tutorial and FAQ: how to call a method on an int
resolution: duplicate
stage: resolved
2014-11-26 23:36:12josh.rsetnosy: + josh.r
messages: + msg231733
2014-11-26 16:01:08jordansetnosy: + jordan
messages: + msg231719
2014-11-26 14:32:25sfalkcreate