classification
Title: IDLE hangs on OS X with Cocoa Tk if encoding dialog is required during save
Type: behavior Stage: resolved
Components: IDLE Versions: Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, steipe, terry.reedy
Priority: normal Keywords:

Created on 2014-11-18 19:09 by steipe, last changed 2017-06-23 07:09 by terry.reedy. This issue is now closed.

Messages (3)
msg231338 - (view) Author: Boris (steipe) Date: 2014-11-18 19:09
When attempting to save a file containing an Å character with the debugger open, IDLE freezes with/or without partially opening the warning window. (Mac OS X 10.9.5, IDLE running python 2.7.5). Reproducible steps:

- Create and save file with one line:
1+1  # A
- Open IDLE
- Open the debugger
- Open the file
- Delete the "A", type <shift><alt>A
- type <command>s to save. This triggers the problem.

Application hangs ("not responding") and needs to force quit. Sometimes the graphics memory of other applications gets corrupted.
msg231353 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-11-19 00:31
Thanks for the report.  It appears that all that is needed to trigger the hang is any operation that invokes the IDLE EncodingMessage dialog ("Non-ASCII found, yet no encoding declared. Add a line like [...]") in IOBinding.py during a Save when IDLE is linked with the OS X Cocoa Tk 8.5 (or likely 8.6) as used with the python.org 64-bin/32-bit 10.6+ installers, for example, just opening a new edit window, inserting a non-ASCII character, and then trying to Save.  EncodingMessage subclasses the Tkinter SimpleDialog module and creates a new Toplevel root; I seem to recall other problems like this in the past.  The problem is not seen with the older Carbon Tk 8.4 or with an X11 Tk on OS X.
msg296684 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-23 07:09
I am no longer patching IDLE for 2.7
History
Date User Action Args
2017-06-23 07:09:45terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg296684

resolution: wont fix
stage: needs patch -> resolved
2014-11-19 00:31:57ned.deilysetnosy: + ned.deily
title: IDLE - MacOS: freeze on non-ASCII save with open debugger -> IDLE hangs on OS X with Cocoa Tk if encoding dialog is required during save
messages: + msg231353

stage: needs patch
2014-11-18 19:09:04steipecreate