classification
Title: Typo in Library's 'threading' module section
Type: Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, r.david.murray, techstone
Priority: normal Keywords: patch

Created on 2014-11-17 15:37 by techstone, last changed 2014-11-17 16:02 by techstone. This issue is now closed.

Files
File name Uploaded Description Edit
threading.rst.patch techstone, 2014-11-17 15:37 Correction diff review
Messages (3)
msg231284 - (view) Author: Martin Gignac (techstone) Date: 2014-11-17 15:37
There is an extraenous asterisk in the constructor description for class 'threading.Thread' in section 17.1.2. "Thread Objects" of the 'threading' module in the Python Standard Library documenation.

(patch attached)
msg231285 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-11-17 15:48
Thanks for taking the time to make a report, but that is not a typo.  That asterisk indicates that daemon is a keyword only argument, and is standard python3 syntax.  You can see it if you follow the source link to the threading module.
msg231286 - (view) Author: Martin Gignac (techstone) Date: 2014-11-17 16:02
Sorry for that. I've read up PEP 3102 and now understand what you meant.

Sorry for the noise.
History
Date User Action Args
2014-11-17 16:02:06techstonesetmessages: + msg231286
2014-11-17 15:48:39r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg231285

resolution: not a bug
stage: resolved
2014-11-17 15:37:18techstonecreate