classification
Title: Include/graminit.h and Python/graminit.c always rebuilt (breaks cross builds)
Type: Stage:
Components: Build, Cross-Build Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: When cross-compiling, don’t try to execute binaries
View: 22625
Assigned To: Nosy List: WanderingLogic, georg.brandl
Priority: normal Keywords:

Created on 2014-11-06 21:12 by WanderingLogic, last changed 2014-11-06 21:37 by georg.brandl. This issue is now closed.

Messages (2)
msg230765 - (view) Author: Matt Frank (WanderingLogic) * Date: 2014-11-06 21:12
changeset 92496:c2a53aa27cad (issue22359) broke cross builds.  (Now "make touch; make" always tries to rebuild Include/graminit.h and Python/graminit.c by running "pgen".  But "pgen" is a host executable and won't run on the build machine during a cross-build.)

I think the problem is here, around Makefile.pre.in line 750.  The dependency was on PGENSRCS and is now on PGEN.  Will changing it back to PGENSRCS break something else?

@@ -745,15 +746,13 @@
 
 $(IO_OBJS): $(IO_H)
 
-$(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGENSRCS)
+$(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
msg230767 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-11-06 21:37
Duplicate of #22625.
History
Date User Action Args
2014-11-06 21:37:12georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg230767

superseder: When cross-compiling, don’t try to execute binaries
resolution: duplicate
2014-11-06 21:12:58WanderingLogiccreate