classification
Title: Intermittent test_tarfile failures on zLinux
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_datetime, test_tarfile, test_strptime time zone failures
View: 20220
Assigned To: Nosy List: David.Edelsohn, berker.peksag, pitrou, serhiy.storchaka, vstinner
Priority: normal Keywords:

Created on 2014-11-04 15:28 by David.Edelsohn, last changed 2014-11-05 17:44 by David.Edelsohn. This issue is now closed.

Messages (5)
msg230630 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2014-11-04 15:30
test_list_command_verbose intermittently fails because the date comparison differs by six hours.  I suspect a bad interaction between tests, but have not been able to find the culprit.

FAIL: test_list_command_verbose (test.test_tarfile.CommandLineTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/mnt/9707/edelsohn/cpython-buildarea/3.x.edelsohn-zlinux-z/build/Lib/test/test_tarfile.py", line 1953, in test_list_command_verbose
    self.assertEqual(out, expected)
AssertionError: b'?rw[39 chars]-01-05 18:19:43 ustar/conttype \n?rw-r--r-- ta[6470 chars]f \n' != b'?rw[39 chars]-01-06 00:19:43 ustar/conttype \n?rw-r--r-- ta[6470 chars]f \n'
msg230693 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-11-05 16:05
This is a duplicate of issue20220.
msg230697 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2014-11-05 17:19
Sorry, I was not aware of the other issue.  Three tests seems to have intermittent failures.

test_datetime
test_tarfile
test_strptime
msg230698 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2014-11-05 17:37
I found the connection but I don't know the cause:

Running test_imaplib prior to either test_datetime or test_tarfile causes the latter test to fail.  test_datetime seems to fix the problem for test_tarfile if it precedes it.

[1/3] test_imaplib
[2/3] test_datetime
test test_datetime failed -- multiple errors occurred; run in verbose mode for details
[3/3/1] test_tarfile
2 tests OK.
1 test failed:
    test_datetime


[1/3] test_imaplib
[2/3] test_tarfile
test test_tarfile failed -- Traceback (most recent call last):
  File "/mnt/9707/edelsohn/src/cpython/Lib/test/test_tarfile.py", line 1953, in test_list_command_verbose
    self.assertEqual(out, expected)
AssertionError: b'?rw[39 chars]-01-05 18:19:43 ustar/conttype \n?rw-r--r-- ta[6470 chars]f \n' != b'?rw[39 chars]-01-06 00:19:43 ustar/conttype \n?rw-r--r-- ta[6470 chars]f \n'

[3/3/1] test_datetime
test test_datetime failed -- multiple errors occurred; run in verbose mode for details
1 test OK.
2 tests failed:
    test_datetime test_tarfile
msg230700 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2014-11-05 17:44
Its the @run_with_tz decorations in test_imaplib and test_datetime.  The TZ is not being restored after the test.
History
Date User Action Args
2014-11-05 17:44:39David.Edelsohnsetmessages: + msg230700
2014-11-05 17:37:51David.Edelsohnsetmessages: + msg230698
2014-11-05 17:19:13David.Edelsohnsetmessages: + msg230697
2014-11-05 16:05:40serhiy.storchakasetstatus: open -> closed
superseder: test_datetime, test_tarfile, test_strptime time zone failures
messages: + msg230693

resolution: duplicate
stage: resolved
2014-11-04 15:45:48berker.peksagsetnosy: + berker.peksag, serhiy.storchaka

versions: + Python 3.4, Python 3.5, - Python 3.6
2014-11-04 15:30:53David.Edelsohnsetnosy: + pitrou

messages: + msg230630
title: Intermittent -> Intermittent test_tarfile failures on zLinux
2014-11-04 15:28:27David.Edelsohncreate