classification
Title: TclStackFree: incorrect freePtr. Call out of sequence?
Type: crash Stage: resolved
Components: Library (Lib), Tkinter, Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Charleston, serhiy.storchaka, steve.dower, tcaswell, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2014-10-29 03:19 by Charleston, last changed 2016-10-24 19:46 by zach.ware. This issue is now closed.

Messages (3)
msg230196 - (view) Author: Fay (Charleston) Date: 2014-10-29 03:19
I have a code that graphs streaming data in a new window. If the cursor is within the graphing window and the cursor has been moved, the graphing window would crash and the message says that "python.exe has stopped working". In the CMD window, the following error is displayed:
"TclStackFree: incorrect freePtr. Call out of sequence?
This application has requested the Runtime to terminate it in an unusual way. 
Please contact the application's support team for more information." 
I've tried changing from python 2.7.7 to 2.7.8 and matplotlib-1.3.1 to 1.4.2. The problem persists in both cases.
msg230197 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-10-29 03:47
This is fairly wild speculation on my part, but I think Python is likely at the bottom of the suspect list for whose bug this is, after (in order):

1) your own code
2) matplotlib
3) Tcl/Tk

I would suggest trying to come up with the shortest reproducer you can (which should shine light on any bugs in your code), report your problem to matplotlib[1] with that reproducer attached, and link between this issue and that one so we can all keep track of it.  We'll keep this report open until somebody claims the bug.

Adding Serhiy as the resident Tkinter expert, in case you have insight I don't.

[1] https://github.com/matplotlib/matplotlib/issues
msg262799 - (view) Author: Thomas Caswell (tcaswell) * Date: 2016-04-02 16:40
I do not think this got reported to mpl, is a year and a half old, and has no example, probably can be closed.
History
Date User Action Args
2016-10-24 19:46:11zach.waresetstatus: pending -> closed
resolution: not a bug
stage: test needed -> resolved
2016-10-24 19:35:21serhiy.storchakasetstatus: open -> pending
2016-04-02 16:40:21tcaswellsetnosy: + tcaswell
messages: + msg262799
2014-10-29 07:45:57serhiy.storchakasetstage: test needed
2014-10-29 03:47:38zach.waresetnosy: + serhiy.storchaka
messages: + msg230197
2014-10-29 03:19:14Charlestoncreate