classification
Title: suggestion for improving wording on len(s) (built-in function)
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ethan.furman, r.david.murray, skrah, vy0123
Priority: normal Keywords:

Created on 2014-10-27 10:49 by vy0123, last changed 2014-10-28 02:10 by vy0123. This issue is now closed.

Messages (4)
msg230068 - (view) Author: Van Ly (vy0123) * Date: 2014-10-27 10:49
-- suggest the following because 
-- the parenthetical parts interrupt the reading too often

len(s)

Returns a length count, the number of objects in argument s which may be a sequence, or mapping: a string, list or tuple, or a dictionary.
msg230073 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2014-10-27 13:41
The original wording is clearer (this also applies to similar issues
that have been opened recently).
msg230096 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-10-27 19:21
Agreed.  The original follows the rules of standard written English (especially as regards to punctuation), while the suggested replacement does not.
msg230113 - (view) Author: Van Ly (vy0123) * Date: 2014-10-28 02:10
(Well that is a stick in the mud and slap in the face attitude to different ways of describing what is there.) You have the documentation for len(s) perfect, __for_everyone__.
History
Date User Action Args
2014-10-28 02:10:14vy0123setmessages: + msg230113
2014-10-27 19:21:31r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg230096

resolution: not a bug
stage: resolved
2014-10-27 13:41:27skrahsetnosy: + skrah
messages: + msg230073
2014-10-27 13:31:42ethan.furmansetnosy: + ethan.furman
2014-10-27 10:49:44vy0123create