classification
Title: "There is no disk in the drive" error
Type: Stage: resolved
Components: IO, Windows Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Lachlan.Kingsford, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2014-10-27 06:53 by Lachlan.Kingsford, last changed 2014-11-01 00:13 by terry.reedy. This issue is now closed.

Messages (3)
msg230060 - (view) Author: Lachlan Kingsford (Lachlan.Kingsford) Date: 2014-10-27 06:53
An error is being raised that 'There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\DR1. Cancel, Try Again, Continue)'.

The line of code referred to has no reference to any file or disk access. None of its calling procedures have any file or disk access. As such, I am fairly confident that the error is not caused by an error in my code.

The Python interpreter was embedded via cx_freeze. The embedded interpreter was Win64 running on 64 bit Windows 7. The computer that reported the bug did not have Python installed on it.

I have been unable to replicate the bug. Similar bugs have been reported due to USB sticks and phones, but none were plugged in or removed while the program was being run.

At this stage, I am unsure if this is a bug with Windows, cx_freeze, or pygame. The bug is also listed on https://github.com/lkingsford/AtlasWarriors/issues/5, with access to the source available. You can view the stack trace and an image of the error, and the stack trace there.

I am not sure if this is a known issue but I am unable to find any reference to it.
msg230063 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2014-10-27 09:04
I very much doubt that this is a Python issue as such.

Other things being equal, I would expect Harddisk\DR1 to be a CD-ROM or
some other removable disk. Using something like winobj.exe from
sysinternals should show what it expects to be on a given machine. It's
certainly possible that the machine on which cx_freeze is being used has
a permanent D: drive while the corresponding drive on the target machine
is removable.

(Strictly Harddisk\DR1 needn't be the D: drive and it needn't be
removable, but that's far and away the most common configuration).

I obviously can't say why any code should be be trying to access that
drive. You could try running procexp.exe (sysinternals again) to see
what handle is being attempted on that drive by that program which might
lend a clue as to where the problem is arising. But, again, I don't
believe this is a Python issue.
msg230415 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-11-01 00:13
Lachian, I am closing this because I agree with Tim.  This tracker is for bug fixes (and enhancements) to the code at hg.python.org/cpython (and a couple of the sibling repositories). Bugs need to be demonstrated with a .py or .c program. This is almost certain a bug somewhere else. In the meanwhile, this report will remain here and be searchable.
History
Date User Action Args
2014-11-01 00:13:49terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg230415

resolution: not a bug
stage: resolved
2014-10-27 09:04:51tim.goldensetmessages: + msg230063
2014-10-27 06:53:47Lachlan.Kingsfordcreate