classification
Title: A Better Help File
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: FCK, docs@python, r.david.murray
Priority: normal Keywords:

Created on 2014-10-22 05:08 by FCK, last changed 2014-10-23 11:01 by FCK. This issue is now closed.

Messages (4)
msg229796 - (view) Author: James (FCK) Date: 2014-10-22 05:08
Just the General Help that is in Python, doesn't really help.  Here's what would help, if every Module, had an example in code of how it was used instead of the Trees.  I mean, word trees, well that's what the writing reminds me of, is word trees like you'd produce in an English class.  But, a short working piece of code, does allot more for me, than a lecture, you'd have to take a course to understand because of it's use of it's own writing style.  It doesn't help to type help() and hit enter.
msg229797 - (view) Author: James (FCK) Date: 2014-10-22 05:23
Just the General Help that is in Python, doesn't really help.  Here's what would help, if every Module, had an example in code of how it was used instead of the Trees.  I mean, word trees, well that's what the writing reminds me of, is word trees like you'd produce in an English class.  But, a short working piece of code, does allot more for me, than a lecture, you'd have to take a course to understand because of it's use of it's own writing style.  It doesn't help to type help() and hit enter.

Honestly, the old old version of Quick Basic, that once came with every version of windows back in the 90s.  It's help, is a template that I think Python, should follow.
msg229821 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-10-22 13:25
The help isn't targeted at teaching you to use the module.  The help is targeted at *reminding* you how to use the module after you've read the full documentation, which usually does contain examples (though generally not at the top of the page...they are usually at the bottom or interspersed...it is a *reference* guide after all, the tutorial is a separate thing with yet a different target).  I'm afraid, though, that if you find the help to be a wall of words, you'll find the library reference worse.  You might be best serve by checking out the book/website "Python Module of the Week" (pymotw.com), which has a more tutorial style and more examples.

I've never see the Quick Basic style docs.  I don't know if that style would be applicable to Python modules.

Bottom line right now, though, is that this isn't really a useful issue for the bug tracker.  If you want to discuss strategies for making overall improvements in the documentation, that's something that should be done with the group of people who focus on documentation.  Their mailing list is docs@python.org if you want to join the team and advocate for a change (your suggestion has already been posted to that mailing list by the bug tracker, FYI).
msg229867 - (view) Author: James (FCK) Date: 2014-10-23 11:01
I've written several languages, I'm no novice but, I also know when to brush 
up.Its just how I started, it looks like an opening for others.

-----Original Message----- 
From: R. David Murray
Sent: Wednesday, October 22, 2014 6:25 AM
To: geek.moses@gmail.com
Subject: [issue22691] A Better Help File

R. David Murray added the comment:

The help isn't targeted at teaching you to use the module.  The help is 
targeted at *reminding* you how to use the module after you've read the full 
documentation, which usually does contain examples (though generally not at 
the top of the page...they are usually at the bottom or interspersed...it is 
a *reference* guide after all, the tutorial is a separate thing with yet a 
different target).  I'm afraid, though, that if you find the help to be a 
wall of words, you'll find the library reference worse.  You might be best 
serve by checking out the book/website "Python Module of the Week" 
(pymotw.com), which has a more tutorial style and more examples.

I've never see the Quick Basic style docs.  I don't know if that style would 
be applicable to Python modules.

Bottom line right now, though, is that this isn't really a useful issue for 
the bug tracker.  If you want to discuss strategies for making overall 
improvements in the documentation, that's something that should be done with 
the group of people who focus on documentation.  Their mailing list is 
docs@python.org if you want to join the team and advocate for a change (your 
suggestion has already been posted to that mailing list by the bug tracker, 
FYI).

----------
nosy: +r.david.murray
resolution:  -> not a bug
stage:  -> resolved
status: open -> closed

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue22691>
_______________________________________
History
Date User Action Args
2014-10-23 11:01:38FCKsetmessages: + msg229867
2014-10-22 13:29:18r.david.murraylinkissue22694 superseder
2014-10-22 13:27:19r.david.murraylinkissue22692 superseder
2014-10-22 13:25:07r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg229821

resolution: not a bug
stage: resolved
2014-10-22 05:23:04FCKsetmessages: + msg229797
2014-10-22 05:08:23FCKcreate