classification
Title: SyntaxError in the configure_ctypes
Type: behavior Stage: resolved
Components: Cross-Build Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, berker.peksag, bill9889
Priority: normal Keywords:

Created on 2014-10-17 17:11 by bill9889, last changed 2016-04-11 07:40 by berker.peksag. This issue is now closed.

Messages (3)
msg229584 - (view) Author: Billy (bill9889) Date: 2014-10-17 17:11
Hi all,

I have a issue with the cross-compilation, here I let it:

  File "../src/setup.py", line 1849
    exec(f.read(), globals(), fficonfig)
SyntaxError: unqualified exec is not allowed in function 'configure_ctypes' it contains a nested function with free variables
make[1]: *** [sharedmods] Error 1

Who wants to help me, please

Best regards.
msg238842 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2015-03-21 22:49
Without more detail I very much doubt that anybody can help.
msg263171 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-04-11 07:40
Thanks for the report.

I think this is a problem in your dev environment (wrong path or something like that). For some reason, you are trying to run Python 3 setup.py in Python 2.
History
Date User Action Args
2016-04-11 07:40:55berker.peksagsetstatus: open -> closed

type: compile error -> behavior

nosy: + berker.peksag
messages: + msg263171
resolution: not a bug
stage: resolved
2015-03-21 22:49:51BreamoreBoysetnosy: + BreamoreBoy
messages: + msg238842
2014-10-17 17:11:55bill9889create