classification
Title: IMAP4 Example lacking host information
Type: Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: imaplib.IMAP4() ends with "Name or service not known" on Fedora 18
View: 18540
Assigned To: docs@python Nosy List: James.Goodwin, docs@python, r.david.murray
Priority: normal Keywords:

Created on 2014-10-17 16:46 by James.Goodwin, last changed 2014-10-17 18:42 by r.david.murray. This issue is now closed.

Messages (3)
msg229581 - (view) Author: James Goodwin (James.Goodwin) Date: 2014-10-17 16:46
The IMAP4 Example for Python 3.4 (Section 21.15.2) does not show the appropriate host information for the example to work.  

Suggested fix would be to change the line "M = imaplib.IMAP4()" to "M = imaplib.IMAP4('localhost')"  This will bring the example inline with the poplib example (Section 21.14.2).
msg229582 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-10-17 16:50
I think this is actually a bug, rather than a doc bug.  See issue 18540.  if you agree, we'll close this as a duplicate of that one.
msg229583 - (view) Author: James Goodwin (James.Goodwin) Date: 2014-10-17 17:01
I do see that.  I agree that this is a duplicate of that one.
History
Date User Action Args
2014-10-17 18:42:57r.david.murraysetstatus: open -> closed
superseder: imaplib.IMAP4() ends with "Name or service not known" on Fedora 18
resolution: duplicate
stage: resolved
2014-10-17 17:01:15James.Goodwinsetmessages: + msg229583
2014-10-17 16:50:10r.david.murraysetnosy: + r.david.murray
messages: + msg229582
2014-10-17 16:46:30James.Goodwincreate