classification
Title: [regression] Lib/ssl.py still references _ssl.sslwrap
Type: Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: alex, benjamin.peterson, christian.heimes, doko, dstufft, giampaolo.rodola, janssen, pitrou, python-dev
Priority: release blocker Keywords: needs review, patch

Created on 2014-09-30 12:50 by doko, last changed 2014-10-02 03:54 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
issue22523.diff alex, 2014-10-01 21:51
issue22523.diff alex, 2014-10-01 22:11
issue22523.diff alex, 2014-10-02 02:13
Messages (7)
msg227896 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2014-09-30 12:50
the backport in issue #21308 caused this regression. _ssl.sslwrap is still referenced in some files.
msg227899 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2014-09-30 12:55
forwarded from https://bugs.debian.org/762010
msg228129 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2014-10-01 21:51
Attached patch sound fix the issue. I guess this function has no tests :-(
msg228131 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2014-10-01 22:05
My patch is incomplete, I'm working on an improved one.
msg228132 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2014-10-01 22:11
New patch resolves the issue. Turns out there were tests, but they weren't being run. Now they are.
msg228150 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2014-10-02 02:13
Updated patch fixes a refcounting issue spotted by gutworth.
msg228156 - (view) Author: Roundup Robot (python-dev) Date: 2014-10-02 03:54
New changeset 1a36d4e8cf4e by Benjamin Peterson in branch '2.7':
fix sslwrap_simple (closes #22523)
https://hg.python.org/cpython/rev/1a36d4e8cf4e
History
Date User Action Args
2014-10-02 03:54:03python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg228156

resolution: fixed
stage: resolved
2014-10-02 02:13:43alexsetfiles: + issue22523.diff

messages: + msg228150
2014-10-01 22:11:35alexsetfiles: + issue22523.diff

messages: + msg228132
2014-10-01 22:05:56alexsetmessages: + msg228131
2014-10-01 21:51:58alexsetkeywords: + patch, needs review
files: + issue22523.diff
messages: + msg228129
2014-09-30 12:55:31dokosetmessages: + msg227899
2014-09-30 12:50:56dokocreate