classification
Title: IDLE closes all when in dropdown menu
Type: crash Stage: resolved
Components: IDLE Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mandolout, terry.reedy
Priority: normal Keywords:

Created on 2014-09-16 07:51 by mandolout, last changed 2014-09-30 05:50 by terry.reedy. This issue is now closed.

Messages (2)
msg226942 - (view) Author: Brunel (mandolout) Date: 2014-09-16 07:51
While python shell is running if the user puts a period after a statement and waits for the dropdown list to pop up, then closes python shell the following will happen:

IDLE will close all active windows immediately, regardless of any unsaved progress (which is lost.)
msg227111 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-09-19 18:35
I cannot reproduce with Idle 3.4.1 on Win 7.

Attempt 1: open Idle from icon (opens shell), edit file, make trivial change, return to shell, and type 'sys.'.  When box appears, close shell, editor left untouched.

Attempt 2: edit another file, type 'sys.', wait for box, and close editor 2.  "Do you want to save before closing' message box appears. Click no, editor 2 closes, editor 1 is left untouched.

Closing behavior has been patched in the last year or so. I suspect you are using an older and obsolete Idle.  I also suspect everything closes because of an internal error now fixed.  Start Idle from a console (command prompt) window with 'python -m idlelib' and I suspect you will see a traceback.

Please either close this or provide a detailed scenario, including OS, using 2.7.8 or 3.4.1, that someone can reporduce.
History
Date User Action Args
2014-09-30 05:50:15terry.reedysetresolution: not a bug
stage: resolved
2014-09-29 23:37:48mandoloutsetstatus: open -> closed
2014-09-19 18:35:40terry.reedysetnosy: + terry.reedy
messages: + msg227111
2014-09-16 07:51:50mandoloutcreate