classification
Title: Typo in docs - Lib/random
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: benrodrigue, docs@python, eric.araujo, ezio.melotti, georg.brandl, r.david.murray
Priority: normal Keywords:

Created on 2014-08-27 15:17 by benrodrigue, last changed 2014-08-27 15:30 by r.david.murray. This issue is now closed.

Messages (2)
msg225990 - (view) Author: Ben Rodrigue (benrodrigue) Date: 2014-08-27 15:17
Small typo: 

In the documentation for the random module. The documentation refers to the semi-open range and then gives an example using a left bracket and then a curved parenthesis on the right. 

Link to page:https://docs.python.org/3.4/library/random.html

From text:"which generates a random float uniformly in the semi-open range [0.0, 1.0)"  

I am new to programming but I believe this to be incorrect. If there is a way to submit a patch for the documentation, I am happy to do so.
msg225994 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-08-27 15:30
That's mathematical notation, not python syntax.  Note that in the html it is *not* styled as a literal code snippet.
History
Date User Action Args
2014-08-27 15:30:33r.david.murraysetstatus: open -> closed

type: behavior

nosy: + r.david.murray
messages: + msg225994
resolution: not a bug
stage: resolved
2014-08-27 15:17:31benrodriguecreate