classification
Title: Document how to use Concurrent Build when using MsBuild
Type: enhancement Stage: resolved
Components: Documentation, Windows Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, docs@python, python-dev, sbspider, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2014-08-24 00:31 by sbspider, last changed 2014-10-26 03:59 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
readme.patch sbspider, 2014-08-24 01:52 Patch file for readme, outlining method to perform concurrent builds. review
readme.patch sbspider, 2014-08-30 10:16 review
Messages (14)
msg225775 - (view) Author: (sbspider) * Date: 2014-08-24 00:31
I was building the cpython code a while back, and noticed that the build system was using msbuild, when 
PCBuild\built.bad -e -d 
was ran. Upon further investigation, it seems that the /m compiler flag is not included. This flag would allow for concurrent builds, considerably speeding up the build time. Therefore, I would like to propose the addition of the /m flag to the build.bat file, so that builds on multi-core systems can be considerable accelerated.
msg225781 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-24 01:38
No need, you can supply it yourself :).  Try 'PCbuild\build.bat -d -e /m'.  That won't work on 3.4, but will on 3.5+; I specifically made sure extra arguments were passed along to msbuild when I rewrote PCbuild\build.bat a while back just so that this would work.

(I don't want to make /m the default and force those who don't want it to turn it off because I've had some odd results using it before that I haven't had a chance to look into.)
msg225782 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-24 01:40
On the other hand, I did fail to document that little gem.  It should be added to the section about build.bat in PCbuild/readme.txt.
msg225783 - (view) Author: (sbspider) * Date: 2014-08-24 01:42
Would you mind letting me do the honors? First time contributing and all that :P
msg225784 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-24 01:45
Of course, I'll be happy to review and commit for you.
msg225790 - (view) Author: (sbspider) * Date: 2014-08-24 02:26
I uploaded the file, just checking if it hasn't come through.
msg225792 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-24 03:57
Patch came through fine; you've done perfectly process-wise.  I'll
post a review of the patch soon.
msg225802 - (view) Author: (sbspider) * Date: 2014-08-24 08:38
Ok, thank you. Just wanted to confirm this, as I plan to help out on the code/documentation as well (and hence want to understand the process beforehand). I look forward to working on Python in the future.
msg226054 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-29 06:08
I finally managed to get a review posted on Rietveld, which should have sent you an email (sorry for the delay!).
msg226104 - (view) Author: (sbspider) * Date: 2014-08-29 23:27
How do you want me to about fixing the issues you suggested - another patch?
msg226106 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-29 23:42
Another patch would be perfect :)
msg226133 - (view) Author: (sbspider) * Date: 2014-08-30 10:16
Uploaded a new patch.
msg230022 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-10-26 03:57
New changeset f35403bf8c91 by Zachary Ware in branch 'default':
Issue #22261: Add a note to PCbuild\readme.txt about MSBuild switches.
https://hg.python.org/cpython/rev/f35403bf8c91
msg230023 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-10-26 03:59
I finally made it back to this and committed a tweaked version of your patch.  Thanks for the report and patch!
History
Date User Action Args
2014-10-26 03:59:45zach.waresetstatus: open -> closed
resolution: fixed
messages: + msg230023

stage: needs patch -> resolved
2014-10-26 03:57:53python-devsetnosy: + python-dev
messages: + msg230022
2014-08-30 10:16:02sbspidersetfiles: + readme.patch

messages: + msg226133
2014-08-29 23:42:29zach.waresetmessages: + msg226106
2014-08-29 23:27:11sbspidersetmessages: + msg226104
2014-08-29 06:08:28zach.waresetmessages: + msg226054
2014-08-24 08:38:17sbspidersetmessages: + msg225802
2014-08-24 03:57:30zach.waresetmessages: + msg225792
2014-08-24 02:26:44sbspidersetmessages: + msg225790
2014-08-24 01:52:02sbspidersetfiles: + readme.patch
keywords: + patch
2014-08-24 01:45:51zach.waresetmessages: + msg225784
2014-08-24 01:42:35sbspidersetmessages: + msg225783
2014-08-24 01:41:48zach.waresetcomponents: + Windows
title: Concurrent Build when using MsBuild -> Document how to use Concurrent Build when using MsBuild
2014-08-24 01:40:33zach.waresetstatus: closed -> open

assignee: docs@python
components: + Documentation, - Build

nosy: + docs@python
messages: + msg225782
resolution: not a bug -> (no value)
stage: resolved -> needs patch
2014-08-24 01:38:22zach.waresetstatus: open -> closed
versions: - Python 3.4
messages: + msg225781

resolution: not a bug
stage: resolved
2014-08-24 00:45:36BreamoreBoysetnosy: + tim.golden, BreamoreBoy, zach.ware, steve.dower
2014-08-24 00:31:27sbspidercreate