classification
Title: Activating a venv - Dash doesn't understand source
Type: enhancement Stage:
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: vinay.sajip Nosy List: dlintott, docs@python, eric.araujo, ezio.melotti, vinay.sajip
Priority: normal Keywords:

Created on 2014-08-07 09:55 by dlintott, last changed 2014-08-07 12:01 by vinay.sajip. This issue is now closed.

Messages (4)
msg225001 - (view) Author: Daniel Lintott (dlintott) Date: 2014-08-07 09:55
In the documentation for venv (https://docs.python.org/3.5/library/venv.html) it gives examples for activating the venv under bash/zsh.

For a long time under both Debian and Ubuntu the default shell has been Dash (https://wiki.ubuntu.com/DashAsBinSh)

Dash doesn't undertsand the command 'source' so instead the venv must be activated using the . command (as is done for Fish, but using the bash activate file instead)
msg225003 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2014-08-07 10:21
dash is the default system shell used to execute scripts (i.e. /bin/sh), not the default shell used for users login shell and terminal emulators.

The venv/scripts/poxis/activate file seems to require bash anyway: running checkbashisms on it warns about “hash -r”.
msg225005 - (view) Author: Daniel Lintott (dlintott) Date: 2014-08-07 10:56
Hmm... just double checked this and this time has worked with the source command (previously was telling me it couldn't be found).

Have double checked and indeed the default login shell is bash

So feel free to close this issue
msg225007 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2014-08-07 12:01
Was there a reason you couldn't close it yourself?
History
Date User Action Args
2014-08-07 12:01:38vinay.sajipsetstatus: open -> closed
resolution: not a bug
messages: + msg225007
2014-08-07 10:56:05dlintottsetmessages: + msg225005
2014-08-07 10:21:41eric.araujosetassignee: docs@python -> vinay.sajip

messages: + msg225003
nosy: + vinay.sajip
2014-08-07 09:59:06georg.brandlsetnosy: - georg.brandl
2014-08-07 09:58:56dlintottsettitle: Actiavting a venv - Dash doesn't understand source -> Activating a venv - Dash doesn't understand source
2014-08-07 09:58:00dlintottsetnosy: + georg.brandl, ezio.melotti, eric.araujo
2014-08-07 09:55:45dlintottcreate