classification
Title: ellipsis needs better display in lexer documentation
Type: Stage: resolved
Components: Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: François-René.Rideau, loewis, r.david.murray
Priority: normal Keywords:

Created on 2014-08-05 16:30 by François-René.Rideau, last changed 2015-04-09 14:47 by r.david.murray. This issue is now closed.

Messages (3)
msg224854 - (view) Author: François-René Rideau (François-René.Rideau) Date: 2014-08-05 16:30
As a followup to http://bugs.python.org/issue21972

The ellipsis (three dots) should be displayed in the box on top of section 2.6 of the reference manual, and not just in the text below:
https://docs.python.org/3.5/reference/lexical_analysis.html
msg224888 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2014-08-05 20:55
I don't think that ... is a delimiter. Instead, it is a literal of the ellipsis class.
msg240332 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-04-09 14:47
I agree that there is nothing to do here.  The ... does not belong in the table, since as Martin says it is a literal, not a delimiter.  In theory you could create a whole new section named 'elipsis literal' above the delmiiters section, but that hardly seems worthwhile, specially since the mention of the special elipsis literal makes more *sense* exactly where it is, after one learns that the period is a delimiter.
History
Date User Action Args
2015-04-09 14:47:20r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg240332

resolution: not a bug
stage: resolved
2014-08-05 20:55:43loewissetnosy: + loewis
messages: + msg224888
2014-08-05 16:30:10François-René.Rideaucreate