classification
Title: string formatting float rounding errors
Type: behavior Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Larry, ned.deily
Priority: normal Keywords:

Created on 2014-08-04 17:29 by Larry, last changed 2014-08-04 20:47 by ned.deily. This issue is now closed.

Messages (2)
msg224747 - (view) Author: (Larry) Date: 2014-08-04 17:29
Certain values close to the rounding boundary are rounded down instead of up; and this is done somewhat inconsistently.


#Example (python v2.7.8, and previous)

#almost an odd-even pattern, but not quite
for x in [1.045, 1.145, 1.245, 1.345, 1.445, 1.545, 1.645, 1.745, 1.845, 1.945]:
    print "{0:.3f} => {0:.2f}".format(x)

#while ..6 rounds up correctly
for x in [1.046, 1.146, 1.246, 1.346, 1.446, 1.546, 1.646, 1.746, 1.846, 1.946]:
    print "{0:.3f} => {0:.2f}".format(x)
msg224773 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-08-04 20:47
What you are seeing is due to the limitations of binary floating-point arithmetic.  The issue is described in more detail in the Python tutorial:

https://docs.python.org/2/tutorial/floatingpoint.html#tut-fp-issues
History
Date User Action Args
2014-08-04 20:47:14ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg224773

resolution: not a bug
stage: resolved
2014-08-04 17:29:57Larrycreate