classification
Title: Rotating items of list to left
Type: behavior Stage: resolved
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Sai.Krishna.G, zach.ware
Priority: normal Keywords:

Created on 2014-08-02 20:35 by Sai.Krishna.G, last changed 2014-08-02 21:34 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
rotate_left3.py Sai.Krishna.G, 2014-08-02 20:35
Messages (2)
msg224586 - (view) Author: Sai Krishna G (Sai.Krishna.G) Date: 2014-08-02 20:35
Hi, I am trying to rotate list of 3 to left
for this I am trying to define this function
def rotate_left3(nums)

#argument nums is list
for example
rotate_left3([1, 2, 3])
I am expecting value [2,3,1] in return. I have written the following code
    a = nums
    a[0]=nums[1]
    a[1]=nums[2]
    a[2]=nums[0]
    return a #this is returning [2,3,2] instead of [2,3,1]
however if I assign
a = [0,0,0] #or any other value other than directly assigning nums
the code works perfectly
msg224590 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-08-02 21:34
This is not a bug. The assignment "a = nums" doesn't create a copy of "nums", it just assigns the name "a" to the same object that "nums" refers to.  Since lists are mutable, changes made to "a" are visible through the name "nums".  By the time you do "a[2] = nums[0]", "nums[0]" has been reassigned.

Have a look at this article: http://nedbatchelder.com/text/names.html

Also, you may want to look at collections.deque and its rotate method.
History
Date User Action Args
2014-08-02 21:34:29zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg224590

resolution: not a bug
stage: resolved
2014-08-02 20:35:33Sai.Krishna.Gcreate