classification
Title: Idle: Hang during File "Save As"
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.4
process
Status: closed Resolution: later
Dependencies: Superseder:
Assigned To: Nosy List: Joe, terry.reedy
Priority: normal Keywords:

Created on 2014-07-30 03:04 by Joe, last changed 2014-08-05 05:12 by Joe. This issue is now closed.

Files
File name Uploaded Description Edit
PythonHang201408011146.txt Joe, 2014-08-04 04:10
Messages (5)
msg224286 - (view) Author: Joe Gaspard (Joe) Date: 2014-07-30 03:04
Python 3.4.1 hang while trying to save a file on  29 July 2014 5Pm.  The computer was a "DIY" i7/WIN7-64 bit/INTEL DZ87KLT-75 Motherboard (w/ Intel i7-4770-K 3.5 GHz processor).   IDLE was operating on "G:\python.exe 3.4.1 (v3.4.1:c0e311e010fc, May 18 2014 10:45:13) [MSC v.1600 64 bit (AMD64] on win 32"
The hang occurred when  a "file save as" operation was attempted.  The file was a display of a "print" of a 400,000 line result from a 3-loop nested "while" count ".py" program.  NOTE: The "make test" set was run a few days earlier and did not result in any messages (all ok).  Thanks - "py" is a great proram and excellent docs.   

Description:
  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name:	AppHangB1
  Application Name:	pythonw.exe
  Application Version:	0.0.0.0
  Application Timestamp:	5378731e
  Hang Signature:	7efa
  Hang Type:	2048
  OS Version:	6.1.7601.2.1.0.768.3
  Locale ID:	1033
  Additional Hang Signature 1:	7efa98bee311c458b7449fe89d922f8b
  Additional Hang Signature 2:	271f
  Additional Hang Signature 3:	271ff7b6e5aa15e9ab2854edd8b040b6
  Additional Hang Signature 4:	7efa
  Additional Hang Signature 5:	7efa98bee311c458b7449fe89d922f8b
  Additional Hang Signature 6:	271f
  Additional Hang Signature 7:	271ff7b6e5aa15e9ab2854edd8b040b6
msg224526 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-08-01 22:57
What file were you trying to save to? Be very exact. Reading/Saving to 'Library' files is known to have problems and there is another issue for this.

Were you trying to save the Shell window, displaying output from your program. 

What is the minimum # of lines required to have a problem.  400000 lines is probably "won't fix" because the problem is likely with tk and Windows, not Idle.  Your program should print directly to a file.
msg224678 - (view) Author: Joe Gaspard (Joe) Date: 2014-08-04 04:10
Thanks Terry.  As best I can recall was trying to save a ".py" while 
IDLE and the "'.py" file were both open, but definitely not a 
'Library' file.  I did try to save the IDLE window display once, and 
it may have been this time.  My programs have been much smaller than 
400000 lines (53 KB max), but I have saved a 500 billion byte file on 
the same 2TB hard drive without a problem.

Attached is a WordPad doc describing two additional problems that 
happened a little while ago.  Python is new to me.  Would I have 
fewer problems if I used an earlier version?  Thanks again for the 
help   ....  Joe Gaspard

At 03:57 PM 8/1/2014, you wrote:

>Terry J. Reedy added the comment:
>
>What file were you trying to save to? Be very exact. Reading/Saving 
>to 'Library' files is known to have problems and there is another 
>issue for this.
>
>Were you trying to save the Shell window, displaying output from 
>your program.
>
>What is the minimum # of lines required to have a problem.  400000 
>lines is probably "won't fix" because the problem is likely with tk 
>and Windows, not Idle.  Your program should print directly to a file.
>
>----------
>nosy: +terry.reedy
>title: Hang during File "Save As" -> Idle: Hang during File "Save As"
>
>_______________________________________
>Python tracker <report@bugs.python.org>
><http://bugs.python.org/issue22105>
>_______________________________________
msg224680 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-08-04 05:14
The latest version is best. We are gradually fixing crashes, closes, hangs, and other bugs.

When you replay by email, please delete the quoted message, as it is redundant with the message already displayed and just noise.

I am closing this issue for now because there is insufficient data to do anything. We can only work on semi-repeatable problems that occur on more than just one user's machine. Windows, at least, is prone to unrepeatable and sometimes system-specific glitches.
msg224806 - (view) Author: Joe Gaspard (Joe) Date: 2014-08-05 05:12
Today the "memory" problem repeated, and I was ale to get more info:

While displaying results of program execution in IDLE, two "memory 
problem" pop-ups were displayed.  Selecting  " recovery activate" 
buttons did not help.  The lower right "Ln count" was 5,xxx,xxx, but 
had not changed for apx one hour (it won't advance unless I click on 
the IDLE window).  Estimated "Ln count" was apx 7,5xxx,xxx at time of 
computer lock up.  CTRL.ALT.DEL eventually restored control of 
Windows (WIN7-64 bit) by using the Status window which also displayed 
98% memory.  A "tk" reference was also displayed before computer 
control was re-established.

My program execution requires printing a line after an "if - else" 
statement.  If I "#comment" the line immediately following  "if" in 
order to reduce the "Ln count", execution will go to the unwanted 
"else" block.  I have not been able to work around this problem.  The 
"else" statement needs to wait for a "Ln count"of apx 10,xxx,xxx, but 
the memory problem occurs at apx 7,5xx,xxx.

Hope this info is of some use.  The only solutions I can think of are 
ones that would allow 10+ million IDLE line prints, or a way around 
the "if -else" problem.
Thanks for the help, I understand your priorities. ... Joe Gaspard

At 10:14 PM 8/3/2014, you wrote:

>Terry J. Reedy added the comment:
>
>The latest version is best. We are gradually fixing crashes, closes, 
>hangs, and other bugs.
>
>When you replay by email, please delete the quoted message, as it is 
>redundant with the message already displayed and just noise.
>
>I am closing this issue for now because there is insufficient data 
>to do anything. We can only work on semi-repeatable problems that 
>occur on more than just one user's machine. Windows, at least, is 
>prone to unrepeatable and sometimes system-specific glitches.
>
>----------
>resolution:  -> later
>stage:  -> resolved
>status: open -> closed
>type:  -> behavior
>
>_______________________________________
>Python tracker <report@bugs.python.org>
><http://bugs.python.org/issue22105>
>_______________________________________
History
Date User Action Args
2014-08-05 05:12:12Joesetmessages: + msg224806
2014-08-04 05:14:40terry.reedysetstatus: open -> closed
type: behavior
messages: + msg224680

resolution: later
stage: resolved
2014-08-04 04:10:06Joesetfiles: + PythonHang201408011146.txt

messages: + msg224678
2014-08-01 22:57:10terry.reedysetnosy: + terry.reedy

messages: + msg224526
title: Hang during File "Save As" -> Idle: Hang during File "Save As"
2014-07-30 03:04:05Joecreate