classification
Title: bdist_wininst does not run install script
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: PyCFunction_New no longer exposed by python DLL breaking bdist_wininst installers
View: 21354
Assigned To: Nosy List: Cybjit, mb_, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2014-07-29 21:44 by mb_, last changed 2014-10-02 05:58 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
foo.zip mb_, 2014-07-29 21:44
Messages (4)
msg224258 - (view) Author: Michael Büsch (mb_) * Date: 2014-07-29 21:44
The bdist_wininst installer does not run the specified --install-script.

Attached is an example project foo.zip.
setup.py is invoked as follows:
py setup.py bdist_wininst --install-script foo_postinstall.py

The installer shows that it successfully ran the install script, but it did not do this. The file C:\foo.txt is not created. If I add print()s to the install script, these messages are not shown either.

I tested this on Python 3.4, 64-bit (Win7) and 32-bit (XP)
msg227722 - (view) Author: (Cybjit) Date: 2014-09-27 20:19
Probably caused by issue #21354
msg228109 - (view) Author: (Cybjit) Date: 2014-10-01 19:38
3f7d5c235d82 runs script, 70ea05f762a1 does not.

0c8f41ca9c94 + t.patch from #21354 does not run script.
msg228133 - (view) Author: (Cybjit) Date: 2014-10-01 22:29
Turns out I had a build problem (#11598).
0c8f41ca9c94 + t.patch does actually solve the problem.
History
Date User Action Args
2014-10-02 05:58:20ned.deilysetstatus: open -> closed
superseder: PyCFunction_New no longer exposed by python DLL breaking bdist_wininst installers
resolution: duplicate
stage: resolved
2014-10-01 22:29:06Cybjitsetmessages: + msg228133
2014-10-01 19:38:29Cybjitsetmessages: + msg228109
2014-09-27 22:13:03ned.deilysetnosy: + tim.golden, zach.ware, steve.dower
2014-09-27 20:19:10Cybjitsetnosy: + Cybjit
messages: + msg227722
2014-07-29 21:44:12mb_create