classification
Title: Grammatical error in 3.4 tutorial
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Jeremy.Fusco, docs@python, r.david.murray
Priority: normal Keywords:

Created on 2014-07-02 19:32 by Jeremy.Fusco, last changed 2014-07-02 21:18 by Jeremy.Fusco. This issue is now closed.

Messages (3)
msg222120 - (view) Author: Jeremy Fusco (Jeremy.Fusco) Date: 2014-07-02 19:32
https://docs.python.org/3/tutorial/controlflow.html

Sentence states 'most such' where either would suffice.

current: In most such cases, however, it is convenient to use the enumerate() function, see Looping Techniques

Proposed: In most cases
msg222125 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-07-02 21:11
It is correct English as written.  If you said just 'most cases', it would be ambiguous (most cases of using...something not quite clear from context, it could be range, or looping, or...), whereas if you said 'such cases', that would be wrong, since not all cases where you could use range and an index are served by using enumerate.  'most such' correctly refers specifically to the preceding example, and qualifies it that not all such cases can use enumerate.  (See what I did there? :)
msg222127 - (view) Author: Jeremy Fusco (Jeremy.Fusco) Date: 2014-07-02 21:18
I do, however I feel I'm not the only one that would be thrown by this wording. Perhaps wording such as 'In cases like the above it is more convenient to utilize the enumerate()'.

Thanks for the quick response!
History
Date User Action Args
2014-07-02 21:18:29Jeremy.Fuscosetmessages: + msg222127
2014-07-02 21:11:44r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg222125

resolution: not a bug
stage: resolved
2014-07-02 19:32:52Jeremy.Fuscocreate