classification
Title: .hgignore: Missing ignores for downloaded doc build tools
Type: Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: andymaier, r.david.murray
Priority: normal Keywords: patch

Created on 2014-07-01 14:55 by andymaier, last changed 2014-07-02 16:13 by andymaier. This issue is now closed.

Files
File name Uploaded Description Edit
issue21900.diff andymaier, 2014-07-01 14:56 Patch for Python 2.7 only.
Messages (5)
msg222041 - (view) Author: Andy Maier (andymaier) * Date: 2014-07-01 14:55
In Python 2.7 and up to Python 3.3, the documentation build process downloads tools such as Sphinx etc. into the Doc/tools subtree. The .hgignore file misses entries to ignore those.

The additional lines for .hgignore would be:
    ^Doc/tools/docutils/
    ^Doc/tools/jinja2/
    ^Doc/tools/pygments/
    ^Doc/tools/sphinx/

This change applies to 2.7 only (assuming 3.1-3.3 are no longer patched).
msg222054 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-07-01 18:34
The entries are there for 2.7.  And indeed for the 3.x versions to which they applied.
msg222101 - (view) Author: Andy Maier (andymaier) * Date: 2014-07-02 13:15
That is indeed true; i just verified that by creating a new clone repository. Sorry for the extra work.

When I created the bug yesterday, I had my repository clone updated to "2.7" and the .hgignore definitely did not have the entries. I even saw all the downloaded doc tools in the status window of my hg client (which is what caused me to attempt to fix this in the first place).

I did do a commit to my local repository clone but did not push that (I would not have the rights anyway).

If anyone has an explanation on whyt I saw, I'd be grateful.

Andy
msg222104 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-07-02 13:41
Are you sure your checkout was updated to 2.7?  If you had checked out 2.7, built the docs, then checked out 3.4 and done an hg status, you would see the Doc files as untracked.  If you were really checked out to 2.7 you shouldn't have.  I doubt there's any way to figure out what went wrong unless you can reproduce it.  Regardless, though, you are having a Mercurial issue here, not a Python one :)
msg222111 - (view) Author: Andy Maier (andymaier) * Date: 2014-07-02 16:13
> Regardless, though, you are having a Mercurial issue here, not a Python one :)

That seems to be the case ... I don't think I can reproduce it.

All fine then.
Thanks, David!
History
Date User Action Args
2014-07-02 16:13:46andymaiersetmessages: + msg222111
2014-07-02 13:41:12r.david.murraysetmessages: + msg222104
2014-07-02 13:15:03andymaiersetmessages: + msg222101
2014-07-01 18:34:40r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg222054

resolution: not a bug
stage: resolved
2014-07-01 14:56:30andymaiersetfiles: + issue21900.diff
keywords: + patch
2014-07-01 14:55:29andymaiercreate