classification
Title: Python3 can't detect Tcl/Tk 8.6.1
Type: Stage: resolved
Components: Build Versions: Python 3.4
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: Joe.Borg, ned.deily
Priority: normal Keywords:

Created on 2014-06-30 15:11 by Joe.Borg, last changed 2014-06-30 18:23 by ned.deily. This issue is now closed.

Messages (2)
msg221964 - (view) Author: Joe Borg (Joe.Borg) Date: 2014-06-30 15:11
Trying to configure 3.4.1 on Cent OS 6.4.  I have built Tcl and Tk, using the prefix /scratch/root.  I can confirm the builds with:

$ find /scratch/root/ -name "tcl.h"
/scratch/root/include/tcl.h

$ find /scratch/root/ -name "tk.h"
/scratch/root/include/tk.h

But, when configuring Python, they aren't picked up:

$ ./configure --prefix=/scratch/root --with-tcltk-includes=/scratch/root/include --with-tcltk-libs=/scratch/root/lib | grep tcl
checking for --with-tcltk-includes... /scratch/root/include
checking for --with-tcltk-libs... /scratch/root/lib
checking for UCS-4 tcl... no

I've tried to make install with this, but then get the usual exception from _tkinter.
msg221974 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-06-30 18:23
for the --with-tcltk-includes and -libs options, you need to pass the same cc options that would go on CFLAGS and LDFLAGS.

  ./configure --help
  [...]
  --with-tcltk-includes='-I...'
                          override search for Tcl and Tk include files
  --with-tcltk-libs='-L...'
                          override search for Tcl and Tk libs

So your values should likely look something like:

  --with-tcltk-includes="-I/scratch/root/include"
  --with-tcltk-libs="-L/scratch/root/lib -ltcl8.6 -ltk8.6"
History
Date User Action Args
2014-06-30 18:23:49ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg221974

resolution: works for me
stage: resolved
2014-06-30 15:23:48Joe.Borgsettitle: Python3 can't detect Tcl -> Python3 can't detect Tcl/Tk 8.6.1
2014-06-30 15:11:14Joe.Borgcreate