This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Ambiguous sentence explaining `cycle` in itertools documentation
Type: Stage:
Components: Documentation Versions: Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: Matt.Deacalion.Stevens, docs@python, rhettinger
Priority: low Keywords:

Created on 2014-06-11 18:46 by Matt.Deacalion.Stevens, last changed 2022-04-11 14:58 by admin. This issue is now closed.

Messages (4)
msg220298 - (view) Author: Matt Deacalion Stevens (Matt.Deacalion.Stevens) Date: 2014-06-11 18:46
https://docs.python.org/3.5/library/itertools.html#itertools.cycle

The first sentence sounds a bit ambiguous:
"Make an iterator returning elements from the iterable and saving a copy of each."

Suggestion:
"Make an iterator that returns elements from the iterable and saves a copy of each."
msg220333 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2014-06-12 05:16
I see no real difference here and AFAICT the current wording has not caused any confusion since it was written a decade ago.
msg220348 - (view) Author: Matt Deacalion Stevens (Matt.Deacalion.Stevens) Date: 2014-06-12 13:19
It's probably just me then. The code example is what helped me grasp `cycle`, not the explanation.
msg220378 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2014-06-12 20:04
That's why the code example is there ;-)
History
Date User Action Args
2022-04-11 14:58:04adminsetgithub: 65926
2014-06-12 20:04:18rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg220378
2014-06-12 13:19:12Matt.Deacalion.Stevenssetmessages: + msg220348
2014-06-12 05:16:23rhettingersetpriority: normal -> low
assignee: docs@python -> rhettinger
messages: + msg220333
2014-06-11 18:56:04zach.waresetnosy: + rhettinger

versions: - Python 3.1, Python 3.2, Python 3.3
2014-06-11 18:46:30Matt.Deacalion.Stevenscreate