classification
Title: Platform.win32_ver() shows different values than expected on Windows 8.1
Type: behavior Stage:
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Finding the Windows version getting messier (detect windows 8.1?)
View: 19143
Assigned To: Nosy List: AvivAvital, lemburg, vstinner
Priority: normal Keywords:

Created on 2014-06-09 13:41 by AvivAvital, last changed 2014-06-09 14:21 by vstinner. This issue is now closed.

Messages (2)
msg220089 - (view) Author: Aviv Avital (AvivAvital) Date: 2014-06-09 13:41
On Windows 8.1, win32_ver() returns a Windows 8 version number:

C:\>\Python27\python.exe
Python 2.7.5 (default, May 15 2013, 22:43:36) [MSC v.1500 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import platform
>>> platform.win32_ver()
('8', '6.2.9200', '', 'Multiprocessor Free')
>>> quit()

C:\>ver

Microsoft Windows [Version 6.3.9600]

C:\>
msg220094 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-06-09 14:21
This issue is a duplicate of the issue #19143.
History
Date User Action Args
2014-06-09 14:21:14vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg220094

superseder: Finding the Windows version getting messier (detect windows 8.1?)
resolution: duplicate
2014-06-09 14:01:38r.david.murraysetnosy: + lemburg
2014-06-09 13:41:34AvivAvitalcreate