classification
Title: venv upgrade fails on Windows when copying TCL files
Type: behavior Stage: resolved
Components: Library (Lib), Tkinter, Windows Versions: Python 3.3, Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: hashstat, python-dev, vinay.sajip
Priority: normal Keywords: patch

Created on 2014-06-04 18:21 by hashstat, last changed 2014-06-05 08:32 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
venv-upgrade.patch hashstat, 2014-06-04 18:21 Patch to test for TCL directory before attempting to create it.
Messages (2)
msg219766 - (view) Author: BC (hashstat) Date: 2014-06-04 18:21
When upgrading a virtual environment on Windows with venv, the following error is encountered:

Error: [WinError 183] Cannot create a file when that file already exists: 'C:\\Users\\user\\Documents\\sandbox\\Lib\\tcl8.6'

Affects both Python 3.3.5 and 3.4.1. Tested on Windows 7 SP1.

Steps to reproduce:

1. Create a virtual environment with venv:

   C:\Users\user\Documents>c:\Python34\python.exe -m venv sandbox

2. Upgrade the virtual environment:

   C:\Users\user\Documents>c:\Python34\python.exe -m venv --upgrade sandbox
   Error: [WinError 183] Cannot create a file when that file already exists: 'C:\\Users\\user\\Documents\\sandbox\\Lib\\tcl8.6'
msg219787 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-06-05 08:32
New changeset 477e71004040 by Vinay Sajip in branch '3.4':
Issue #21663: Fixed error caused by trying to create an existing directory.
http://hg.python.org/cpython/rev/477e71004040

New changeset 1ed9edde3bfc by Vinay Sajip in branch 'default':
Closes #21663: Merged fix from 3.4.
http://hg.python.org/cpython/rev/1ed9edde3bfc
History
Date User Action Args
2014-06-05 08:32:38python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg219787

resolution: fixed
stage: resolved
2014-06-04 19:37:57berker.peksagsetnosy: + vinay.sajip
2014-06-04 18:21:29hashstatcreate