classification
Title: Syntax error in Modules/config.c
Type: Stage:
Components: Build Versions:
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: gvanrossum, twouters
Priority: low Keywords:

Created on 2000-10-07 15:41 by anonymous, last changed 2000-10-07 16:26 by gvanrossum. This issue is now closed.

Messages (3)
msg1958 - (view) Author: Nobody/Anonymous (nobody) Date: 2000-10-07 15:41
After ./configure has terminated, file Modules/config.c
contains the following two erroneous lines:

[config.c]
   ...
   extern void initlocal/lib(void);
   ...
   {"local/lib", initlocal/lib},   
   ...

This happened on a Sun Ultra 1 with SunOS 5.6.
msg1959 - (view) Author: Thomas Wouters (twouters) * (Python committer) Date: 2000-10-07 15:54
Hm,  how did you run configure ? Any special options you passed to it ? Also, did you edit Modules/Setup or Modules/Setup.local ? And what are the contents of Modules/Setup.config ? That local/lib looks like a line was wrapped incorrectly, in one of those files, which makes 'makesetup' think it needs to define a module called 'local/lib'.

When in doubt, do a 'make distclean' and start from scratch, making a fresh copy of Modules/Setup.in and making sure to edit it with an editor that does not wrap lines ('joe' is my personal favorite, but YMMV ;)

(Priority lowered because the cause is highly likely to be a typo/linewrap in one of the Setup files. I added a request in PEP 42 for makesetup to grow syntax checking. Not closed yet, until it's clear that this is indeed the cause.)
msg1960 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2000-10-07 16:26
This undoubtedly caused by a typo in Modules/Setup. Closed.

You probably have accidentally split a line so that the next line starts with the string "local/lib". This string occurs in several places in the Setup file as distributed. If you want to split a line, add a backslash.
History
Date User Action Args
2000-10-07 15:41:09anonymouscreate