classification
Title: List Dict bug?
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Robert.w, r.david.murray
Priority: normal Keywords:

Created on 2014-06-01 17:51 by Robert.w, last changed 2014-06-01 18:59 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
bug.py Robert.w, 2014-06-01 17:51
Messages (2)
msg219513 - (view) Author: Robert w (Robert.w) Date: 2014-06-01 17:51
outer for loop loops n > 1 times, when it should loop one time.

Variations are possible tht the bug doesn't occur.
msg219517 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-06-01 18:59
If I put a 'print("one iteration") at the top of the loop, that string is printed exactly once.  I presume you realized that and that is why you closed this?
History
Date User Action Args
2014-06-01 18:59:50r.david.murraysetresolution: not a bug

messages: + msg219517
nosy: + r.david.murray
2014-06-01 17:54:21Robert.wsetstatus: open -> closed
2014-06-01 17:51:21Robert.wcreate