classification
Title: utime can not accept directory under NT
Type: enhancement Stage:
Components: Windows Versions:
process
Status: closed Resolution: later
Dependencies: Superseder:
Assigned To: tim.peters Nosy List: gangli59, tim.peters
Priority: normal Keywords:

Created on 2000-09-12 13:36 by gangli59, last changed 2000-09-16 02:17 by tim.peters. This issue is now closed.

Messages (4)
msg1336 - (view) Author: Gang Li (gangli59) Date: 2000-09-12 13:36
Whenever supply a directory to utime path parameter, exception raised.  The problem is MS C run time library utime function only works on files, but not directories.  To fix this bug, MS utime has to be replaced by some function that works with directory.
msg1337 - (view) Author: Gang Li (gangli59) Date: 2000-09-13 22:49
I submitted a patch that uses win32 api instead MSC run time library
msg1338 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2000-09-15 06:25
Changed to Category "Modules".
msg1339 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2000-09-16 02:17
Moved to PEP42, as extending the functionality of the platform utime is a new feature rather than a bug.  This is a borderline case, so my intent here is not to reject it out-of-hand for the next 2.0 beta, but to classify it as correctly as possible.
History
Date User Action Args
2000-09-12 13:36:26gangli59create