classification
Title: File "C:\Python27\lib\distutils\msvc9compiler.py", line 295, in query_vcvarsal l raise ValueError(str(list(result.keys()))) ValueError: [u'path']
Type: compile error Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: msvc9compiler.py: ValueError when trying to compile with VC Express
View: 7511
Assigned To: Nosy List: Cris, skrah
Priority: normal Keywords:

Created on 2014-04-24 23:42 by Cris, last changed 2014-04-25 09:37 by skrah. This issue is now closed.

Messages (2)
msg217140 - (view) Author: Cris (Cris) Date: 2014-04-24 23:42
I have Windows 8 64bit and Python 64bit (installed from here: https://www.python.org/ftp/python/2.7/python-2.7.amd64.msi)

I also installed pywin32-214.win-amd64-py2.7 (from here http://downloads.sourceforge.net/project/pywin32/pywin32/Build%20214/pywin32-214.win-amd64-py2.7.exe?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fpywin32%2Ffiles%2Fpywin32%2FBuild%2520214%2F&ts=1398376919&use_mirror=kent)

When I try to install Scrapy it gives me this error:

  File "twisted\runner\topfiles\setup.py", line 14, in <lambda>
  File ".\twisted\python\dist.py", line 413, in _check_header
  File ".\twisted\python\dist.py", line 399, in _compile_helper
  File "C:\Python27\lib\distutils\msvc9compiler.py", line 469, in compile
    self.initialize()
  File "C:\Python27\lib\distutils\msvc9compiler.py", line 379, in initialize
    vc_env = query_vcvarsall(VERSION, plat_spec)
  File "C:\Python27\lib\distutils\msvc9compiler.py", line 295, in query_vcvarsal
l
    raise ValueError(str(list(result.keys())))
ValueError: [u'path']

How can I fix it?
msg217157 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2014-04-25 09:37
This looks like a duplicate of #7511.
History
Date User Action Args
2014-04-25 09:37:13skrahsetstatus: open -> closed

superseder: msvc9compiler.py: ValueError when trying to compile with VC Express

nosy: + skrah
messages: + msg217157
resolution: duplicate
stage: resolved
2014-04-24 23:42:29Criscreate