classification
Title: IDLE crash on OS X 10.9 upon shut-down with many windows open
Type: behavior Stage: resolved
Components: IDLE, macOS, Tkinter Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE crash on OS X 10.9 upon shut-down with many windows open
View: 21339
Assigned To: Nosy List: ned.deily, rhettinger, ronaldoussoren, serhiy.storchaka, terry.reedy
Priority: normal Keywords:

Created on 2014-04-24 00:45 by rhettinger, last changed 2014-10-02 22:43 by terry.reedy. This issue is now closed.

Messages (4)
msg217105 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2014-04-24 00:45
*** Internal Error: rpc.py:SocketIO.localcall()

 Object: gui_adapter 
 Method: <bound method GUIAdapter.interaction of <idlelib.RemoteDebugger.GUIAdapter instance at 0x120e71f80>> 
 Args: ('bug.py:1: <module>()', 4350545536, None)

Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/idlelib/rpc.py", line 188, in localcall
    ret = method(*args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/idlelib/RemoteDebugger.py", line 284, in interaction
    self.gui.interaction(message, frame, modified_info)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/idlelib/Debugger.py", line 198, in interaction
    b.configure(state="disabled")
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk/Tkinter.py", line 1262, in configure
    return self._configure('configure', cnf, kw)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk/Tkinter.py", line 1253, in _configure
    self.tk.call(_flatten((self._w, cmd)) + self._options(cnf))
TclError: invalid command name ".4846984656.4846982712.4846983792"
msg228263 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-10-02 21:54
Which tk? Did you ever activate Debugger in the session (known problem, see #15347)? Can you reproduce this with a series of step you can post? How were you shutting down (I have had problems with 'Close Windows on a Windows Taskbar icon right-click menu)?
msg228268 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-10-02 22:17
From the traceback, it does appear that the debugger was in use.  Since there's not much else to go on here, I suggest closing this as a duplicate of #15347.
msg228276 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-10-02 22:43
I added a note to #21339 about the traceback here.
History
Date User Action Args
2014-10-02 22:43:47terry.reedysetstatus: open -> closed
superseder: IDLE crash on OS X 10.9 upon shut-down with many windows open
messages: + msg228276

resolution: duplicate
stage: resolved
2014-10-02 22:43:47terry.reedylinkissue21339 superseder
2014-10-02 22:17:28ned.deilysetassignee: ronaldoussoren ->
messages: + msg228268
title: IDLE crash on OS X 1.9 upon shut-down with many windows open -> IDLE crash on OS X 10.9 upon shut-down with many windows open
2014-10-02 21:54:04terry.reedysetnosy: + terry.reedy, serhiy.storchaka, ned.deily, ronaldoussoren
messages: + msg228263

assignee: ronaldoussoren
components: + macOS, Tkinter
type: behavior
2014-04-24 00:45:14rhettingercreate