This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: IDLE not opening
Type: Stage: resolved
Components: Versions: Python 3.3
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE on OS X fails with Attribute Error if no initial shell and Tk out-of-date
View: 18270
Assigned To: Nosy List: chester.burns, ned.deily
Priority: normal Keywords:

Created on 2014-03-07 08:00 by chester.burns, last changed 2022-04-11 14:57 by admin. This issue is now closed.

Messages (4)
msg212863 - (view) Author: Chester Burns (chester.burns) Date: 2014-03-07 08:00
I installed python 3.3.3 and it was working fine for the moment, however the next day when I tried to open it, the idle app showed on the dock for a second and straight away quit.  I am using a macbook pro on osx version 10.9.1
msg212864 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-07 08:06
Try launching IDLE from a Terminal shell window by typing:


and see if it fails there and, if so, any messages shown.  One possibility is the problem reported in which was fixed in the IDLE shipped with Python 3.3.4.
msg212866 - (view) Author: Chester Burns (chester.burns) Date: 2014-03-07 09:31
I tried that and it came up with this:

Traceback (most recent call last):
  File "/usr/local/bin/idle3.3", line 5, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/idlelib/", line 1572, in main
    shell.interp.runcommand(''.join(("print('", tkversionwarning, "')")))
AttributeError: 'NoneType' object has no attribute 'interp'

I also tried typing 'open /usr/local/bin/idle3.3' and it returned this:

No application knows how to open /usr/local/bin/idle3.3.
msg212867 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-07 09:35
Thanks for the update.  That is indeed the symptom of the problem documented in Issue18270.  The best solution is to download and install Python 3.3.4 which has a fix for it.
Date User Action Args
2022-04-11 14:57:59adminsetgithub: 65062
2014-03-07 18:40:45ned.deilysetstatus: open -> closed
2014-03-07 09:35:38ned.deilysetsuperseder: IDLE on OS X fails with Attribute Error if no initial shell and Tk out-of-date
resolution: duplicate
messages: + msg212867
stage: resolved
2014-03-07 09:31:48chester.burnssetmessages: + msg212866
2014-03-07 08:06:53ned.deilysetnosy: + ned.deily
messages: + msg212864
2014-03-07 08:00:48chester.burnscreate