classification
Title: Embedding with zipped standard library is broken in 3.3.4 (Windows)
Type: crash Stage: resolved
Components: Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Issue with zipimport in 3.3.4 and 3.4.0rc1
View: 20621
Assigned To: Nosy List: Andrey.Antsut, ned.deily
Priority: normal Keywords:

Created on 2014-03-04 22:33 by Andrey.Antsut, last changed 2014-03-04 23:26 by ned.deily. This issue is now closed.

Messages (4)
msg212744 - (view) Author: Andrey Antsut (Andrey.Antsut) Date: 2014-03-04 22:33
When embedding Python into C++, Py_Initialize() crashes with following errors if the standard library (python33\lib) is in a zip archive (e.g. python33.zip):

Fatal Python error: Py_Initialize: unable to load the file system codec
ImportError: No module named 'encodings'

This seems to be specific to Python 3.3.4: works fine with 3.3.2 and 3.3.3, not tested with other versions. Tested only on Windows.

More details with code examples can be found here:

http://stackoverflow.com/questions/22174760/embedding-python-3-3-in-c-from-zipped-standard-library-on-windows-xp
msg212747 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-04 22:54
This is most likely a duplicate of Issue20621.  A fix for the problem is the primary motivation for a new maintenance release for which a release candidate is now available.  It would be great if you could test with 3.3.5rc2 and confirm that the problem no longer occurs with it.

http://www.python.org/download/releases/3.3.5/
msg212749 - (view) Author: Andrey Antsut (Andrey.Antsut) Date: 2014-03-04 23:25
Just checked - confirming that it works with 3.3.5rc2.
msg212750 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-03-04 23:26
Great, thanks!
History
Date User Action Args
2014-03-04 23:26:21ned.deilysetstatus: open -> closed

messages: + msg212750
2014-03-04 23:25:29Andrey.Antsutsetstatus: pending -> open

messages: + msg212749
2014-03-04 22:54:39ned.deilysetstatus: open -> pending

superseder: Issue with zipimport in 3.3.4 and 3.4.0rc1

nosy: + ned.deily
messages: + msg212747
resolution: duplicate
stage: resolved
2014-03-04 22:33:30Andrey.Antsutcreate