classification
Title: 3.4 cherry pick: 6a1711c96fa6 (Popen.__del__ traceback)
Type: behavior Stage: commit review
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: larry Nosy List: barry, doko, larry, serhiy.storchaka, vstinner
Priority: release blocker Keywords:

Created on 2014-02-28 15:12 by barry, last changed 2014-03-07 11:03 by larry. This issue is now closed.

Messages (11)
msg212443 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2014-02-28 15:12
This commit fixes the traceback we're seeing on Ubuntu with Python 3.4, in Popen.__del__ on interpreter shutdown.
msg212444 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2014-02-28 15:12
http://bugs.python.org/issue19021
msg212702 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-03-04 10:25
Link to the changeset: 6a1711c96fa6
msg212716 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-03-04 11:16
This issue is a regression of Python 3.4 compared to Python 3.3. subprocess is major module and so 6a1711c96fa6 must be into Python 3.4.0.
msg212823 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-03-06 17:31
According to #19021, this actually requires six revisions:

6a1711c96fa6
fa160c8145e5
efaf12106d68
7ecee9e0dc58
10ea3125d7b8
488ccbee6ee6

Is that correct?
msg212826 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2014-03-06 17:35
On Mar 06, 2014, at 05:31 PM, Larry Hastings wrote:

>Larry Hastings added the comment:
>
>According to #19021, this actually requires six revisions:
>
>6a1711c96fa6
>fa160c8145e5
>efaf12106d68
>7ecee9e0dc58
>10ea3125d7b8
>488ccbee6ee6
>
>Is that correct?

Yes, at least.  I got sidetracked by Work but am now trying to get back to
this.  I think there maybe other changes needed to get the test suite to fully
pass, but OTOH, the failures I've seen may be due to my poor cherry picking
skills or other changes introduced in Debian/Ubuntu.
msg212831 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-03-06 17:43
What do you want me to do?  Hold off while you determine the correct set of changes, or proceed with these six?

(p.s. rebasing = headache, so having the right set of changes up front would be super-swell.)
msg212834 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-03-06 18:41
Yes, that is correct.

I thought that 6a1711c96fa6 is already in RC1, that is why I hadn't opened cherrypick issue for this. 6a1711c96fa6 is critical change because it not only fixes one annoying warning, but it also fixes wrong order of finalization of modules and other bugs.
msg212837 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2014-03-06 19:07
On Mar 06, 2014, at 06:41 PM, Serhiy Storchaka wrote:

>
>I thought that 6a1711c96fa6 is already in RC1, that is why I hadn't opened
>cherrypick issue for this. 6a1711c96fa6 is critical change because it not
>only fixes one annoying warning, but it also fixes wrong order of
>finalization of modules and other bugs.

I don't think it is, since it applied cleanly to the rc2 tarball.
msg212839 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2014-03-06 19:44
On Mar 06, 2014, at 05:43 PM, Larry Hastings wrote:

>What do you want me to do?  Hold off while you determine the correct set of
>changes, or proceed with these six?

I have just verified that if you take the rc2 tarball and apply these six
changesets, it 1) applies cleanly; 2) completes a "make test" with no errors.
msg212874 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-03-07 11:03
ok.
History
Date User Action Args
2014-03-07 11:03:58larrysetstatus: open -> closed
resolution: fixed
messages: + msg212874
2014-03-06 19:44:01barrysetmessages: + msg212839
2014-03-06 19:07:26barrysetmessages: + msg212837
2014-03-06 18:41:21serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg212834
2014-03-06 17:43:29larrysetmessages: + msg212831
2014-03-06 17:35:32barrysetmessages: + msg212826
2014-03-06 17:31:13larrysetmessages: + msg212823
2014-03-04 11:16:46vstinnersetmessages: + msg212716
2014-03-04 10:25:35vstinnersetnosy: + vstinner
messages: + msg212702
2014-02-28 15:12:26barrysetmessages: + msg212444
2014-02-28 15:12:04barrycreate