classification
Title: AttributeError: 'NoneType' object has no attribute 'returncode'
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, pramod.jadhav
Priority: normal Keywords:

Created on 2014-02-28 06:48 by pramod.jadhav, last changed 2014-02-28 07:38 by ned.deily. This issue is now closed.

Messages (2)
msg212409 - (view) Author: Pramod Jadhav (pramod.jadhav) Date: 2014-02-28 06:48
AttributeError                            Traceback (most recent call last)
<ipython-input-16-c985c6423e2d> in <module>()
      7 #F='C:\Users\Prashant\Documents\IPython Notebooks\resources\ch06-mailboxes'
      8 F='resources/ch06-mailboxes/data/enron.mbox.json.bz2'
----> 9 r = envoy.run("bunzip2 %s" % (F,))
     10 print r.std_out
     11 print r.std_err

C:\Anaconda\lib\site-packages\envoy\core.py in run(command, data, timeout)
    166 
    167         cmd = Command(c)
--> 168         out, err = cmd.run(data, timeout)
    169 
    170         r = Response(process=cmd)

C:\Anaconda\lib\site-packages\envoy\core.py in run(self, data, timeout)
     51             self.process=process;
     52             thread.join()
---> 53         self.returncode = self.process.returncode
     54         return self.out, self.err
     55 

AttributeError: 'NoneType' object has no attribute 'returncode'
msg212410 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-28 07:38
The traceback shows an issue when using envoy, which is not part of the Python standard library.  Assuming you are using the envoy listed in PyPI, I suggest you ask on the project's issue tracker:

https://github.com/kennethreitz/envoy/issues
History
Date User Action Args
2014-02-28 07:38:28ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg212410

resolution: not a bug
stage: resolved
2014-02-28 06:48:58pramod.jadhavcreate