classification
Title: Turn on all tests in test.test_importlib.source.test_file_loader
Type: Stage: needs patch
Components: Library (Lib) Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: brett.cannon Nosy List: brett.cannon, matheus.v.portela
Priority: normal Keywords: easy

Created on 2014-02-27 16:46 by brett.cannon, last changed 2014-03-05 20:24 by brett.cannon. This issue is now closed.

Messages (3)
msg212367 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-02-27 16:46
Some tests have a leading underscore which means they were probably turned off for testing purposes but forgot to be flipped back on. Should turn them back on and make sure that they actually still pass.
msg212766 - (view) Author: Matheus Vieira Portela (matheus.v.portela) * Date: 2014-03-05 18:24
Apparently, the methods with leading underscore are being tested by two classes (SourceLoaderBadBytecodeTest and SourcelessLoaderBadBytecodeTest) that implement methods with similar names (but without the underscore).

Simply removing the underscore breaks the tests since they cannot differ between the methods with and without underscore.
msg212768 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-03-05 20:24
Thanks for checking, Matheus! Closing this as invalid then.
History
Date User Action Args
2014-03-05 20:24:17brett.cannonsetstatus: open -> closed
resolution: not a bug
messages: + msg212768
2014-03-05 18:24:32matheus.v.portelasetnosy: + matheus.v.portela
messages: + msg212766
2014-02-27 16:46:44brett.cannoncreate