classification
Title: Segmentation fault with unoconv
Type: crash Stage: resolved
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Sworddragon, ned.deily
Priority: normal Keywords:

Created on 2014-02-24 02:13 by Sworddragon, last changed 2014-06-21 19:32 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
backtrace.txt Sworddragon, 2014-02-24 02:13 GDB backtrace
test.odt Sworddragon, 2014-02-24 02:14 LibreOffice test document
Messages (5)
msg212052 - (view) Author: (Sworddragon) Date: 2014-02-24 02:13
With Python 3.4.0 RC1 on using the command "unoconv -o test.pdf test.odt" I'm getting a segmentation fault. In the attachments are the used LibreOffice document and a GDB backtrace. The used version of unoconv was 0.6-6 from Ubuntu 14.04 dev and can be currently found here: http://packages.ubuntu.com/de/source/trusty/unoconv
msg212054 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-24 02:22
I don't know anything about these programs but it appears libpyuno.so is linked with a specific version of Python 3.  Was it rebuilt linked against Python 3.4, instead of Python 3.3?

http://packages.ubuntu.com/en/trusty/python3-uno
msg212055 - (view) Author: (Sworddragon) Date: 2014-02-24 02:29
> Was it rebuilt linked against Python 3.4, instead of Python 3.3?

I don't know. Is ../Python/pystate.c that throws the error not a part of Python?
msg212056 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-24 02:36
The point is that you may be inadvertently mixing a shared library (libpyuno.so) linked to a Python 3.3 interpreter with a base Python 3.4 interpreter.  Unless python3-uno is very careful to use the stable ABI there is no guarantee of binary level compatibility between Python versions (3.3 vs 3.4):

http://docs.python.org/dev/c-api/stable.html
msg221192 - (view) Author: (Sworddragon) Date: 2014-06-21 19:27
I have retested this with the correct linked version and it is working fine now so I'm closing this ticket.
History
Date User Action Args
2014-06-21 19:32:54ned.deilysetstage: resolved
2014-06-21 19:27:09Sworddragonsetstatus: open -> closed
resolution: not a bug
messages: + msg221192
2014-02-24 02:36:56ned.deilysetmessages: + msg212056
2014-02-24 02:29:11Sworddragonsetmessages: + msg212055
2014-02-24 02:22:33ned.deilysetnosy: + ned.deily
messages: + msg212054
2014-02-24 02:14:20Sworddragonsetfiles: + test.odt
2014-02-24 02:13:53Sworddragoncreate