classification
Title: Fail to build on Windows x64 with VS Express
Type: compile error Stage: resolved
Components: Build, Windows Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: TomBrander, zach.ware
Priority: normal Keywords:

Created on 2014-02-22 02:57 by TomBrander, last changed 2014-02-28 15:35 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
failedbld.txt TomBrander, 2014-02-22 02:57 Failed build log
Messages (3)
msg211902 - (view) Author: Tom Brander (TomBrander) Date: 2014-02-22 02:57
Trying to build a Win 32 version using VS express on Win 7 (since it cannot do x64) Rev 89320 tried to build python 3.4 from source using VS 2010 express no dice.  It complains about solutions folder that is not supported in VS 2010 express. While this is noted in the read me, I still cannot build whether by GUI or via the build.bat file (I removed the reference to the solutions folder reference) to get it to run at all via the command prompt. Friend next door using full VS 2010 seems ok..
msg211904 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-02-22 03:23
Hi Tom,

Your issue is very strange; I use VS 2010 Express on a regular basis and have never had the error shown in your log.  The "solution folder" thing is no big deal; it's annoying that it reminds you about it every time you open the solution, but just clicking "ok" makes it go away and all is normal after that.  How did you remove the reference to the solution folder?  If you edited pcbuild.sln by hand, that may account for the error you're seeing; it reads to me like your project files have been corrupted.

Here's a few steps to try. Run all of these from the root of the source repository in Command Prompt.  Note that if you have made any changes to the repo, they will be lost completely if you don't save them somewhere outside of the source tree!

Run:
   hg update null
   hg --config extensions.purge= purge
   hg update d6aa3fa646e2
   "%VS100COMNTOOLS%vsvars32.bat"
   msbuild PCbuild\PCbuild.sln
   PCbuild\python_d.exe --version

Those commands will (in order): update the repository to the null revision, clean out the repository completely so you start from nothing, update to a revision that I just built from (so I know it's good :)), set up the environment for building, build Python in debug mode, confirm that Python built.

If the build succeeds following those steps, that should mean that some change you made corrupted the project files.  If not, report back and I'll try again :)
msg212446 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-02-28 15:35
Since I can't reproduce, I'm going to go ahead and close the issue.  If you can reproduce it after following the steps I laid out in my previous message, please re-open this issue.
History
Date User Action Args
2014-02-28 15:35:55zach.waresetstatus: open -> closed
type: compile error
messages: + msg212446

components: + Windows
resolution: not a bug
stage: resolved
2014-02-22 03:23:23zach.waresetnosy: + zach.ware
messages: + msg211904
2014-02-22 02:57:31TomBrandercreate