classification
Title: Sidebar scrolls down 2x as fast as page content
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Arfrever, David.Felix, docs@python, ezio.melotti, georg.brandl, nicktimko, pitrou, python-dev, zach.ware
Priority: normal Keywords:

Created on 2014-02-20 00:01 by nicktimko, last changed 2016-06-02 02:12 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
py34sidebar.png nicktimko, 2014-02-20 00:01 Screenshot of problem with crude hand-drawn annotations.
Messages (8)
msg211675 - (view) Author: Nick Timkovich (nicktimko) * Date: 2014-02-20 00:01
When scrolling down in the Python 3.4 docs (e.g. http://docs.python.org/3.4/library/index.html ) the Sphinx sidebar's top value increases twice as fast as the user moves down the page, resulting in it "running away".

I don't know sufficient JS to identify the problem, but I'm guessing it's somewhere in the sidebar.js:scroll_sidebar() function or whatever might configure it.

(apologies, I *think* I may have sent a similar mail to the docs list already)
msg211687 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-02-20 04:24
I noticed this earlier today as well, but didn't have a chance to report.  I also happened to have a week-old doc page still loaded in the next tab over (which didn't have the problem), and noticed that it was marked as being built by Sphinx 1.2, whereas today's is Sphinx 1.1.3, which I suspect may have something to do with it since I don't see any other major changes to how the docs are built in recent changesets.

Nick: You did report it on docs@, but it was held for moderation since you aren't subscribed.  It has now been approved.
msg211735 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2014-02-20 16:12
Doesn't seem to happen with a local build of the doc tree, using Sphinx 1.2.1.
msg211906 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-02-22 06:32
New changeset b514339e41ef by Benjamin Peterson in branch '2.7':
use sphinx from its own virtualenv (closes #20693)
http://hg.python.org/cpython/rev/b514339e41ef
msg212071 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-02-24 08:37
Not quite fixed yet: this will happen with any build using sphinx1.1, which is supposed to be supported now.
msg212077 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-02-24 09:13
Hmm, I can't reproduce here with 1.1.3.  Can someone build the tip docs locally with Sphinx 1.1.3 and try to reproduce?
msg212133 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2014-02-24 19:10
I can reproduce on tip with Sphinx v1.1.3; seems to work fine on 3.3 and tip with Sphinx v1.2.
msg240456 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2015-04-11 01:29
Is this still a problem?  I haven't noticed it on docs.python.org in quite some time.  Ezio, can you still reproduce?
History
Date User Action Args
2016-06-02 02:12:19berker.peksagsetstatus: pending -> closed
2015-04-11 01:29:02zach.waresetstatus: open -> pending

messages: + msg240456
2014-02-24 19:10:00ezio.melottisetmessages: + msg212133
2014-02-24 09:13:04georg.brandlsetmessages: + msg212077
2014-02-24 08:37:09georg.brandlsetstatus: closed -> open

messages: + msg212071
2014-02-22 06:33:01python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg211906

resolution: fixed
stage: needs patch -> resolved
2014-02-20 16:12:54pitrousetmessages: + msg211735
2014-02-20 16:01:39ezio.melottisetnosy: + pitrou, ezio.melotti

stage: needs patch
2014-02-20 15:43:27zach.warelinkissue20700 superseder
2014-02-20 15:43:21zach.waresetnosy: + David.Felix
2014-02-20 04:44:33Arfreversetnosy: + Arfrever
2014-02-20 04:24:04zach.waresetnosy: + georg.brandl, zach.ware
messages: + msg211687
2014-02-20 00:01:10nicktimkocreate