classification
Title: IDLE Indents convert to spaces and then throws error
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Justin.Barker, terry.reedy
Priority: normal Keywords:

Created on 2014-02-19 22:08 by Justin.Barker, last changed 2014-02-21 22:45 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
test.py Justin.Barker, 2014-02-19 22:08
Messages (2)
msg211664 - (view) Author: Justin Barker (Justin.Barker) Date: 2014-02-19 22:08
When I add some lines to my module code, some of the tabs that I enter convert to spaces.  This throws an inconsistency error and I can't get it to stop!
msg211883 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-02-21 22:45
Questions about how to use python (or Idle) are better directed to python-list or similar forums. In this case, you are asking how to edit a file with tabs in Idle, which converts tabs to spaces on entry. Idle editor windows have a Format menu with Tabify and Untabify options, both of which allow you to select the conversion between tabs and spaces. I personally would untabify the file first and edit. You could re-tabify at the end if needed. Or just edit (with spaces) and tabify the new stuff at the end.
History
Date User Action Args
2014-02-21 22:45:35terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg211883

resolution: not a bug
stage: resolved
2014-02-19 22:08:56Justin.Barkercreate