classification
Title: OpenBSD: timeval.tv_sec type is long, not time_t
Type: Stage: resolved
Components: Versions: Python 3.3, Python 3.4, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: belopolsky, neologix, python-dev, rpointel, vstinner
Priority: normal Keywords: patch

Created on 2014-02-17 11:46 by vstinner, last changed 2014-02-18 08:30 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
pytime_objectotimeval.patch vstinner, 2014-02-17 12:17 review
Messages (7)
msg211410 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-17 11:46
select.select() doesn't work on OpenBSD 64-bit because timeval.tv_sec is a long, whereas Python uses a time_t.

Attached patch should fix this issue.
msg211411 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-17 11:47
Hum, Python 3.3 seems to be also affected. Nobody tried Python 3 on OpenBSD since at lease Python 3.2?
msg211412 - (view) Author: Remi Pointel (rpointel) * Date: 2014-02-17 11:56
Hi,

I think you forgot to attach the diff.

Python 3.3 is in OpenBSD since 5.4.
msg211414 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-17 12:17
> I think you forgot to attach the diff.

Oops.

> Python 3.3 is in OpenBSD since 5.4.

So you should work more with upstream (Python) ;-) => see issue #20657
msg211459 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-18 00:03
> Python 3.3 is in OpenBSD since 5.4.

Oh, it looks like select.select() works fine when I install Python 3.3 from OpenBSD. It's maybe a regression of Python 3.4?
msg211465 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-02-18 00:36
New changeset 79ccf36b0fd0 by Victor Stinner in branch 'default':
Close #20656: Fix select.select() on OpenBSD 64-bit
http://hg.python.org/cpython/rev/79ccf36b0fd0
msg211489 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-02-18 08:30
New changeset 6c186975ee43 by Victor Stinner in branch 'default':
Issue #20656: Restore explicit downcast in select_select().
http://hg.python.org/cpython/rev/6c186975ee43
History
Date User Action Args
2014-02-18 08:30:44python-devsetmessages: + msg211489
2014-02-18 00:36:29python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg211465

resolution: fixed
stage: resolved
2014-02-18 00:03:31vstinnersetmessages: + msg211459
2014-02-17 12:17:23vstinnersetfiles: + pytime_objectotimeval.patch
keywords: + patch
messages: + msg211414
2014-02-17 11:56:44rpointelsetmessages: + msg211412
2014-02-17 11:47:37vstinnersetmessages: + msg211411
versions: + Python 3.3
2014-02-17 11:46:52vstinnercreate