classification
Title: pandas version 0.13.0 does not give warning when summing float with object
Type: Stage:
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mark.dickinson, serrajo
Priority: normal Keywords:

Created on 2014-02-05 14:59 by serrajo, last changed 2014-02-05 15:00 by mark.dickinson. This issue is now closed.

Messages (2)
msg210323 - (view) Author: Simone Serrajotto (serrajo) Date: 2014-02-05 14:59
Good afternoon,
I have just installed pandas 0.13.0 and was observing some strange results
produced by old codes.
One major issue is that I found that when summing two columns of a
dataframe, one of which is a float64 and the other an object, the result
includes just the float64 columns.
This would be not an issue per se, but no warning message is displayed.
I think a warning in this case is of paramount importance.

Regards,
Simone

-- 

Simone Serrajotto

Quaestio Capital Management SGR SpA Unipersonale

Corso Como 15 (8° piano)

20154 Milano

C.F. e P.I. 06803880969

Iscritta all'Albo delle SGR al n. 299

Mobile:  +39 393 919 0217

Tel:           +39 02 3676 5241

E-Mail:        s.serrajotto@quaestiocapital.com<c.prinoth@quaestiocapital.com>

-- 

Le informazioni contenute nella comunicazione che precede sono riservate e 
destinate esclusivamente alla persona o all'ente sopraindicati. La 
diffusione, distribuzione e/o copiatura del presente email o di qualsiasi 
documento allegato da parte di qualsiasi soggetto diverso dal destinatario 
e' proibita. La sicurezza e la correttezza dei messaggi di posta 
elettronica non possono essere garantite. Se avete ricevuto questo 
messaggio per errore, Vi preghiamo di contattarci immediatamente. Grazie

The content of this email is confidential and it is intended for the sole 
use of the addressees. The transmission, distribution and/or copy of this 
email or any document attached hereto by any person other than the 
addressees is prohibited. The transmission of this email cannot be 
guaranteed to be secure or error-free. If you have received this 
communication unintentionally, please inform us immediately. Thank you.
msg210324 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2014-02-05 15:00
Hi Simone,

I'm afraid you've got the wrong bugtracker.  This is the bugtracker for the Python core language (which doesn't include Pandas).  Pandas is a 3rd party project.  You can report Pandas issues here:

https://github.com/pydata/pandas/issues
History
Date User Action Args
2014-02-05 15:00:48mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg210324

resolution: not a bug
2014-02-05 14:59:12serrajocreate