classification
Title: Missing network resource checks in test_urllib2 & test_smtplib
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.4
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: berker.peksag, ncoghlan, ndeininger
Priority: normal Keywords:

Created on 2014-02-02 04:59 by ncoghlan, last changed 2016-09-11 04:54 by berker.peksag. This issue is now closed.

Messages (3)
msg209947 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-02 04:59
These two tests appear to rely on DNS lookups or other network access that isn't guarded by the network resource (my internet dropped out and these two tests failed, but they work correctly now the internet connection is back up).
msg213087 - (view) Author: Nadja Deininger (ndeininger) Date: 2014-03-10 21:15
I tried to reproduce this by disabling my network connection and running these tests, but they worked for me.
msg218756 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2014-05-18 20:47
I couldn't reproduce it either. I also tried related urllib and urllib2 tests:
- test_urllib (passed)
- test_urllibnet (skipped - Use of the 'network' resource not enabled)
- test_urllib_response (passed)
- test_urllib2net (skipped - Use of the 'network' resource not enabled)
- test_urllib2_localnet (passed)
History
Date User Action Args
2016-09-11 04:54:58berker.peksagsetstatus: open -> closed
resolution: works for me
stage: needs patch -> resolved
2014-05-18 20:47:11berker.peksagsetnosy: + berker.peksag
messages: + msg218756
2014-03-10 21:15:44ndeiningersetnosy: + ndeininger
messages: + msg213087
2014-02-02 04:59:35ncoghlancreate